[MPlayer-users] [BUG?] Libavcodec first pass fail with Mulholland drive : get_buffer() failed NOVIRUS

Eric Fernandez e.fernandez at kent.ac.uk
Mon Sep 22 13:09:36 CEST 2003

I have a strange case with a specific DVD : Mulholland Drive Region 1, 
and it may reveal a bug.

Encoding the movie (title 1) or the trailer (title 6) fails after the 
first pass using mencoder 1.0pre1 but was successful with previous 
versions of mencoder (0.91 and below).

Now, at the end of the first pass, mencoder returns (this is obtained 
with the trailer, title 6) :

Movie-Aspect is 1,33:1 - prescaling to correct movie aspect.
get_buffer() failed (0 -2546 0 0x40fa0030)

and the second pass fails immediately. Interestingly, if I interrupt 
with escape the first pass before the end, it works.
The trailer is 2549 frames long, and the error says get_buffer() failed 
(0 -2546 0 0x40fa0030), I guess the problem is at frame 2546.

I used the classical 2-pass strategy :

mencoder -oac copy -o /dev/null -ovc lavc -lavcopts 
vcodec=mpeg4:vbitrate=850:vhq:vpass=1 -vop scale=640:480 -ofps 23.976 
-sws 2
mencoder -oac copy -o md.avi -ovc lavc -lavcopts 
vcodec=mpeg4:vbitrate=850:vhq:vpass=2 -vop scale=640:480 -ofps 23.976 
-sws 2

I tried also using all libavc options by default, still the same 
(removing ofps or sws options)

However :
- mencoder 0.91 was working
- mencoder 1.0pre1 works perfectly using xvid.
- my other region 1 DVD encode correctly using 1.0pre1 and libavcodec
Interestingly, dvdrip works with ffmpeg and mulholland drive trailer. It 
uses transcode to encode video.
So I guess the error is specific to the way mencoder handles ffmpeg, but 
occurs only with Mulholland drive !

Anyone saw such problem before, has anyone got that DVD to confirm ? Is 
there a workaround ? Is it a bug introduced since MPlayer 0.90 ?


More information about the MPlayer-users mailing list