[MPlayer-users] Cannot load subtitles: Wonderful Days DVD Rip/wonderful.days-postx.sub

Anton anton_melser at paradise.net.nz
Sat Sep 20 06:56:33 CEST 2003

I also am having troubles with not being able to get things working. I 
had them working but now can't remember whether I have watched an avi 
with subtitles since I uninstalled (rpm) and installed from source. The 
fonts are there in /usr/share/mplayer/fonts/. Any ideas? Did I forget to 
pass some parameter when installing from source?
ps any other comments on the state of my mplayer are also welcome :-)

[antonovich at localhost cdrom]$ mplayer -sub AmoresPerros.sub AmoresPerros.avi
MPlayer 0.91-3.2.2  (C) 2000-2003 MPlayer Team
CPU: Advanced Micro Devices Athlon 4 PM Palomino/Athlon MP 
Multiprocessor/Athlon XP eXtreme Performance (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or 
Reading config file /home/antonovich/.mplayer/config
Reading /home/antonovich/.mplayer/codecs.conf: can't open 
'/home/antonovich/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: can't open 
'/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
font: can't open file: /home/antonovich/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Failed to open /dev/rtc: Permission denied (mplayer should be setuid 
root or /dev/rtc should be readable by the user.)
Using usleep() timing
Can't open input config file /home/antonovich/.mplayer/input.conf: No 
such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such 
file or directory
Falling back on default (hardcoded) input config

Playing AmoresPerros.avi
AVI file format detected.
VIDEO:  [XVID]  480x384  16bpp  25.00 fps  545.2 kbps (66.6 kbyte/s)
SUB: Detected subtitle file format: microdvd
SUB: Read 1349 subtitles.
SUB: Adjusted 15 subtitle(s).
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 16000->192000 (128.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local 
Disabling DPMS
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
This file was encoded with XviD build 9
VDec: vo config request - 480 x 384 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.25:1 - prescaling to correct movie aspect.
VO: [xv] 480x384 => 480x384 Planar YV12
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
A:   5.9 V:   5.9 A-V: -0.008 ct:  0.051  148/148   3%  5%  0.8% 0 0 0%
Successfully enabled DPMS

Exiting... (End of file)

Nathan Morell wrote:

> [Automatic answer: RTFM (read DOCS, FAQ), also read DOCS/bugreports.html]
>     When trying to play Wonderful Days, I get this error.
>     I've tried to use the -sub option, combined with every other 
> option in 'man mplayer' that could even be related to a sub file; and 
> I think its either something wrong with the file or something. I went 
> through  my huge archive of [mplayer-user] posts and found somebody 
> who said I should try to convert it to utf8? A) I don't know how B) 
> Every time I try to dump the sub file to some other format it gives 
> the same error "Cannot load subtitles"
>     Is there a way I can learn more about "WHY" it can't load those subs?
> --Nathan
> Playing /home/jidar/Wonderful Days DVD Rip/Wonderful.Days-PosTX.avi
> AVI file format detected.
> VIDEO:  [XVID]  608x336  24bpp  23.976 fps  992.4 kbps (121.1 kbyte/s)
> Clip info:
>  Software: Nandub v1.0rc2
> SUB: Detected subtitle file format: subviewer 2.0
> SUB: Read 0 subtitles.
> Cannot load subtitles: /home/jidar/Wonderful Days DVD 
> Rip/wonderful.days-postx.sub
> _______________________________________________
> RTFM!!!  http://www.MPlayerHQ.hu/DOCS
> Search:  http://www.MPlayerHQ.hu/cgi-bin/htsearch
> http://mplayerhq.hu/mailman/listinfo/mplayer-users

More information about the MPlayer-users mailing list