[MPlayer-users] NODAEMON Problems playing a new RTSP stream with MPlayer

Stephen Stocker lpar at par1.net
Wed Sep 10 08:52:21 CEST 2003

> NODAEMON Problems playing a new RTSP stream with MPlayer
>    Steven Ellis mail_lists at stevencherie.net
>    Wed Sep 10 11:03:56 CEST 2003
> I've just tried to play the new REAL based trailers for 24 using
> MPlayer, and sadly failed. I know it isn't a core networking issue as
> realplay will work.
> I'm beginning to wonder if they have done some smarts to detect the user
> agent or if it relates to my firewall. Ive set up the http_proxy
> correctly, but the streams still won't work.
> Currently running MPlayer 1.0pre1-3.2.2
> $ mplayer http://www.fox.com/24/video/preview_hi.rpm
> Gives me -
> Connected to server: www.fox.com
> Cache fill:  0.02% (66 bytes)    Falling back on trying to parse
> playlist http://www.fox.com/24/video/preview_hi.rpm...
> ============ Sorry, this file format is not recognized/supported
> =============
> So I tried grabbing the RPM file with wget and extracting the URL
> $ mplayer
> rtsp://real.fox.speedera.net/real.fox/shows/24/24_season3_large.rm
> Connecting to server real.fox.speedera.net[]:554 ...
> Connect error : No route to host
> Unable to open URL:
> rtsp://real.fox.speedera.net/real.fox/shows/24/24_season3_large.rm
> Option stream url: This URL doesn't have a hostname part.
> File not found: 'real.fox/shows/24/24_season3_large.rm'
> Failed to open
> rtsp://real.fox.speedera.net/real.fox/shows/24/24_season3_large.rm
   Just a thought here. Once in awhile I've run across a .ram or .rpm file which is DOS formatted (CR-LF), and running dos2unix on it solves the problem. No idea why, but it's happened more than once.


More information about the MPlayer-users mailing list