[MPlayer-users] Bug: out of memory

Corey Hickey bugfood-ml at fatooh.org
Sun May 25 18:59:21 CEST 2003

Giuseppe Castagna wrote:
> [Automatic answer: RTFM (read DOCS, FAQ), also read DOCS/bugreports.html]
> I have RH 9 with custom kernel 2.4.21-rc2 configured with kernel
> debugging Check for stack overflows Magic SysRq key. I am running
> Mplayer on a Athlon XP 1700+, Radeon 9500Pro card, Alsa 9.3a drivers
> with a SoundBlaster Live!. I've tried both the MPlayer 0.90 and the cvs
> version and the following error always appear.
> In some well determined points of several DivX files mplayer exits
> because of the following error (in /var/log/messages)
> May 25 16:38:25 lampone kernel: Out of Memory: Killed process 5880
> (gmplayer).
> Note that with the same files I didn't have any problem with the 2.4.20
> kernel. I tried to recompile the kernel with Kernel Hacking off kernel
> rc3 ALSA 9.3c .... crash
> ---Beppe---

Yes, this was reported not long ago, and I can reproduce it here with a
nearly-current CVS build. It happens with gmplayer and alsa9. If you use
the regular non-gui mplayer or -ao oss, it's fine.

...and my reply:

The original reporter didn't say what hardware he was using, but it
happens to me on both my SBLive and my VT8233 (onboard sound). I'll fill
out a full bugreport if somebody tells me it's necessary. Anyone?


More information about the MPlayer-users mailing list