[MPlayer-users] VESA stopped working with Radeon.

TJ tianjy at jippii.fi
Sat May 24 18:44:49 CEST 2003


I wonder if anyone can shed a light on what might have happened since 
outputting to VESA with MPlayer stopped working after upgrading SuSE 8.1 
to 8.2. I'm using compiled MPlayer, of course, not the bundled one. When 
trying to play, everything seems okay except for that no picture is 
shown and MPlayer hangs (with -v) after VO: Comment: Requires ROOT 
privileges. If I don't kill MPlayer soon enough, it will bring the whole 
system down. It seems to use HDD a lot while hanging. The only error 
message shown is that of 'libdhahelper - file not found', which 
shouldn't be a problem since I'm using VESA as a root anyway? I'm not 
sure why it shows or has it been there before, too - libdhahelper is 
installed in /usr/local/lib (which is in ld-conf).

Possible reasons, please comment:

1. Dha?

2. New kernel (SuSE 2.4.20). But: I used 2.4.21pre:s before, and I tried 
2.4.21-rc3 now without any improvement. Counts this one out?

3. New compiler (gcc 3.3-pre). But: I tried two MPlayer 
rpm-installations compiled with earlier gcc:s, with no change in 
behavior. Counts this out?

4. New XFree (4.3.0) and ATI binary drivers (2.9.12). But: I tried 
booting without loading fglrx-module or X, no luck. Counts this out?

5. I messed WinXP Radeon drivers with some tool, had to reinstall 
drivers and stuff. But can this affect outputting to VESA in Linux?! 
VESA is correctly initialized (50Hz PAL) at bootup still, and is so even 
in the console and everything shows on the output, MPlayer just doesn't 
output to VESA.

6. Something else?

I'm becoming desperate, having lost TV-out totally on Linux :( It's so 
frustrating to boot to Windows, and I have only about 10% of the HDD 
dedicated to Win so I can't even keep a lot of video files there, either.

Many thanks for the (possible) answers!


More information about the MPlayer-users mailing list