[MPlayer-users] Can't find codec 'msmpeg4' in libavcodec...

Raena Lea-Shannon raen7 at ihug.com.au
Wed May 21 16:39:12 CEST 2003


I am running MPlayer 0.90pre6-3.2 from SuSE 8.1 install on celeron 600 CPU 
with (yes I know) Nvidia Aladdin card and 368 mb SDR. I have pored over HTML 
DOCS and RTFM many times over and learnt a great deal but it has not got 
through my thick skull why a div3 avi file is not playing video. I have 
played mpegs with sound and audio v good quality (for this PC). I also
upgraded /home/raena/.mplayer/codecs.conf from etc/codecs.conf
then read DOCS/codecs.html! again.

Yet still from

mplayer -vo x11 vc -ffdivx (have also tried ffodivx ffmp41 ffmp42) myfile.avi

I get

Detected AVI file format!
VIDEO:  [DIV3]  352x240  24bpp  29.97 fps  264.0 kbps (32.2 kbyte/s)
Detected audio codec: [mp3] afm:1 (mp3lib MPEG layer-2, layer-3)
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 22050 Hz, 2 ch, sfmt: 0x10 (2 bps), ratio: 5000->88200 (40.0 kbit)
vo: X11 running at 800x600 with depth 16 and 16 bpp (":0" => local display)
Forced video codec: ffdivx
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec: CPU flags: mmx mmxext sse
Can't find codec 'msmpeg4' in libavcodec...
VDecoder init failed :(
Can't find codec matching selected -vo and video format 0x33564944 !
*** Try to upgrade /home/raena/.mplayer/codecs.conf from etc/codecs.conf
*** If it's still not OK, then read DOCS/codecs.html!

Is it the SuSE compile. ie Is it better to remove the SuSE CD install and 
download and compile from scratch?
Raena Lea-Shannon

More information about the MPlayer-users mailing list