[MPlayer-users] compiling error

Alexandre CONRAD aconrad.tlv at magic.fr
Thu Mar 13 14:32:32 CET 2003


I'm running RH 7.2. I tried compiling with gcc 3.2.2, and I got such an 
error :

./configure --with-win32libdir=/usr/local/src/mplayer/w32codec-0.90 
--with-extraincdir=/usr/local/src/DVB/include/ --enable-live 

Checking for gcc version ... 3.2.2, ok

[working, working, working...]

gcc -c -O4 -march=pentium3 -mcpu=pentium3 -pipe -ffast-math 
-fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE 
-D_FILE_OFFSET_BITS=64 -I. -Inative -I.. -I../libmpdemux -I../loader 
-I/usr/local/src/DVB/include/  -D_GNU_SOURCE -o vf_lavc.o vf_lavc.c
vf_lavc.c: In function `config':
vf_lavc.c:65: `FRAME_RATE_BASE' undeclared (first use in this function)
vf_lavc.c:65: (Each undeclared identifier is reported only once
vf_lavc.c:65: for each function it appears in.)
vf_lavc.c: In function `open':
vf_lavc.c:177: `FRAME_RATE_BASE' undeclared (first use in this function)
make[1]: *** [vf_lavc.o] Error 1
make[1]: Leaving directory 
make: *** [libmpcodecs/libmpcodecs.a] Error 2

What can I do ? That's from today's CVS snapshot (MPlayer-20030313). I 
got the CVS because I want to have "RTSP/RTP streaming support for 
MPlayer". And on this page : <http://www.live.com/mplayer/> it says that 
"Download the newest version (the "latest CVS snapshot", not the 'rc' 
version) of the MPlayer source code."

So that's why I'm doing this. I haven't tried with the rc4. Any ideas ? 
But apparently, this comes when compiling the DVB stuff. Right ? I'm 
using the DVB linuxtv-dvb-1.0.0-pre2 driver.


Alexandre CONRAD
Research & Development
tel : +33 1 30 80 55 00
fax : +33 1 30 56 50 20
6, rue de la plaine

More information about the MPlayer-users mailing list