[MPlayer-users] TrueSpeech Codec Problems

Andrew Smith aps at zai.com
Tue Mar 11 21:06:26 CET 2003


I'm encountering problems trying to decode TrueSpeech audio samples
using MPlayer.  I'm using the latest release (0.90rc403.2) and it is
working great for many other audio/video codecs.  It seems like this
problem is specific to the TrueSpeech codec.  I'm pretty sure the
samples I have are "good" (I downloaded them from DSPG, the authors of
the codec).  I can play them successfully on Windows w/ Media Player and
the DSPG win32 player.  

My environment is pretty straightforward, RedHat 8, Pentium III, stock
kernel and compiler versions.  I've tried other builds of MPlayer and
get the same result with all of them.  I've done some trial and error
and I'm pretty sure the Win32 codecs are installed correctly on my linux

I would love to know if anyone has been able to use TrueSpeech

Thanks for any help or suggestions,


p.s.  I can provide the (small, 25kb) sample I'm using as well as the
verbose output of MPLayer if that would help.  A good (I believe) sample
is also available at http://www.dspg.com/samples/85/a6.wav

p.p.s.  The MPlayer output I get at standard verbosity is as follows
(truncated for readability):

-------------------Begin MPlayer Output-----------------
MPlayer 0.90rc4-3.2 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6,
Stepping: 6)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

Playing bunny.tsp
Audio file detected.
Opening audio decoder: [acm] Win32/ACM decoders
Loading codec DLL: 'tssoft32.acm'
External func tsd32.dll:12
External func tsd32.dll:14
External func tsd32.dll:15
External func tsd32.dll:13
External func tsd32.dll:11
Loaded DLL driver tssoft32.acm
Total Unfree 0 bytes cnt 0 [(nil),0]
ACM_Decoder: Unappropriate audio format
Could not load/initialize Win32/ACM AUDIO codec (missing DLL file?).
ADecoder preinit failed :(
ADecoder init failed :(
*** Try to upgrade /home/aps/.mplayer/codecs.conf from etc/codecs.conf
*** If it still does not work, read DOCS/codecs.html!
Cannot find codec for audio format 0x22.
Audio: no sound
Video: no video

Exiting... (End of file)

-------------------------End MPlayer Output--------------------------

More information about the MPlayer-users mailing list