[MPlayer-users] problems with FAAD

mylan.chen at philips.com mylan.chen at philips.com
Tue Mar 11 08:05:05 CET 2003

Hi all,

I tried to use mplayer to play back a test.mov on Linux and have the 
following problems:

1. the test.mov is composed by one AAC audio and MPEG-4 video, the video 
can be decoded, but for the audio, it reports:
MOV track #0: 483 chunks, 483 samples
Audio bits: 16  chans: 1  rate: 44100
Audio extra header: len=97  fcc=0x77617665
Fourcc: mp4a

Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
ADecoder init failed :(
*** Try to upgrade /root/.mplayer/codecs.conf from etc/codecs.conf
*** If it still does not work, read DOCS/codecs.html!

The FAAD is working, and can decode other mp4 files containing AAC track. 
And I use the QT Pro to export MOV to MP4, by choosing "Pass through", 
then the new test.mp4 can be played by mplayer. 

2. I tried to use -dumpaudio and -dumpvideo to get the raw tracks of video 
and audio, and add them to a mp4 file with mpeg4ip tools. But I failed 
with the audio track again. Only the video is correctly added. And that 
audio track is quite different from the audio track extracted from 
test.mp4 generated as above, while the video tracks are the same.

So the problem lies in the format of test.mov or the player? 

Thank you for any hints. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mplayerhq.hu/pipermail/mplayer-users/attachments/20030311/0f0d9bc2/attachment.htm>

More information about the MPlayer-users mailing list