[MPlayer-users] RH8: Can't Use VESA, Even As Root

Dan Yungk daniel.yungk at snet.net
Fri Feb 7 13:49:39 CET 2003


Appreciate your input on this.

I don't believe it's related to su.  That's one of several ways I've
tried to invoke VESA.  Typically, I'll switch over to another console,
and log in from scratch.  I had thought that perhaps being logged in as
both a normal user on an X console, and as root on a text console, might
have something to do with it, so I've rebooted and logged in as root
right from the start, still with no luck.

Is it possible that there's some device or file used that's incorrectly
owned by my normal user ID?  I know Redhat goes through some process
where it assigns ceretain devices to whoever is logged in.  Perhaps root
can't access them in such a case.  Being somewhat new and self-taught on
Linux, I don't know if this theory makes sense, but it's one of the few
that I have right now.

Thanks again.

Increasing The Entropy Of The Universe Since 1972

>How are you su'ing to root?

>If you just do a plain 'su', then you still retain some attributes of
>the unprivileged account you came from. For example, whoami will answer
>'old_user_name', rather than 'root'.

>Running 'su -' will run root's login scripts, etc. and you will appear
>to have logged onto the system as root. In this case, whoami will
>answer 'root'.

>I don't know what has changed between redhat 7 and 8, but the behaviour
>of 'su' may have.

>I don't think this is the real reason behind vidix working and VESA
>not, but it's worth a try. :)

>Chris J.

>> Hello all,
>> I've just switched from Redhat 7.0 to 8.0, and have run into a
>>problem using the VESA driver as root (as a means to output to TV),
>>which worked fine with RH7.  
>> Typically on RH7, I'd switch over to a text console, log in as root,
>> activate TV-Out with the atitvout program, then run mplayer with the
>> -vo vesa:vidix option.  This worked beautifully under Redhat 7, but
>> on Redhat 8, mplayer tells me that this requires root privileges,even
>> though I'm logged in as root.  With RH8, I can be in an X session as 
>> a normal user, su to root, and successfully invoke xvidix from
>> a command line, but never VESA.  

More information about the MPlayer-users mailing list