[MPlayer-users] mencoder segfault or pic-distortion

Andreas Schuldei andreas at schuldei.org
Wed Feb 5 15:17:48 CET 2003

i have tried this with the latest cvs and the stabel release
downloaded in the tar.bz2 file form mplayerhq.hu. the effects are
the same.

I try to encode a series of jpeg or png pics into a simpel movie. 

doing this:

mencoder -mf on:w=800:h=600:fps=2:type=jpg -ovc lavc -lavcopts
           aspect=4/3:vcodec=mpeg4 -o sod.avi /tmp/sod\*.jpg

gives me a segfault:

MEncoder 0.90rc3-2.95.4 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 6)
Detected cache-line size is 32 bytes
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Reading /home/andreas/.mplayer/codecs.conf: 50 audio & 130 video codecs
File not found: 'frameno.avi'
Reading config file /home/andreas/.mplayer/mencoder: No such file or directory
success: format: 0  data: 0x0 - 0x0
forced mf.
[demuxer] mf support.
[mf] search expr: /tmp/sod*.jpg
[mf] number of files: 33 (132)
[V] filefmt:16  fourcc:0x47504A49  size:800x600  fps: 2.00  ftime:=0.5000
Opening video filter: [expand=-1:-1:-1:-1:1]
Expand: -1 x -1, -1 ; -1  (-1=autodetect) osd: 1
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffmjpeg] vfm:ffmpeg (FFmpeg MJPEG decoder)
Writing AVI header...
mjpeg: JFIF header found (version: 1.1)
mjpeg comment: ' Image generated by GNU Ghostscript (device=pnmraw)'
VDec: vo config request - 800 x 600 (preferred csp: Planar 444P)
Could not find matching colorspace - retrying with -vop scale...
Opening video filter: [scale]
VDec: using Planar 444P as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
SwScaler: reducing / aligning filtersize 1 -> 4
SwScaler: reducing / aligning filtersize 9 -> 8
SwScaler: reducing / aligning filtersize 1 -> 1
SwScaler: reducing / aligning filtersize 9 -> 8

SwScaler: BICUBIC scaler, from Planar 444P to Planar YV12 using MMX2
videocodec: libavcodec (800x600 fourcc=58564944 [DIVX])
Segmentation fault

doing the same with png instead lets me encode a movie, but the
pic is totally distorted.  look at it at

i also tried other options for -ovc but i only get flickers,
distorted pics or nothing at all.

is that because i use grayscale pics? 

i generate them with convert from latex output: 
convert -crop 800x600! -density 120x120 -quality 100 sod.ps jpg:sod%03d.jpg

i allso tried to generate color pics by adding -depth 8 or/and
-colorspace CMYK, but with no success.

More information about the MPlayer-users mailing list