[MPlayer-users] Problem with OGM on multi track XCD

marcogi at libero.it marcogi at libero.it
Sun Feb 2 10:50:13 CET 2003


I made some XCD using mode2cdmaker and put on it 4 OGM files into 4
different MODE2 tracks.

mode2cdmaker -f a_description_file.txt -m file1.ogm -m file2.ogm -m
file3.ogm -m file4.ogm -o image

The problem is playing track N, mplayer plays track N _and_ every track
> N.

mplayer -vcd 4

Plays track 4 and 5.
Beetwen track 4 and 5, mplayer says:

OGG : Page out not synced, we skip some bytes
OGG : Page out not synced, we skip some bytes
OGG : bad packet in stream 0
OGG : bad packet in stream 1

And even: mplayer -dumpstream -vcd 2
dumps tracks 2 3 4 5 into one stream.dump
-vcd 3 dumps tracks 3 4 5 and so on.

Same problem if I play tracks from .bin file with:
mplayer -cuefile image.bin -vcd N

I tried mode2cdmaker 1.5a and 1.4.2 with same result

I tried using zplayer on winblows and it works fine :/

Comments, ideas?

mplayer output:
$ mplayer -vcd 4
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale

MPlayer CVS-030104-22:00-3.2.2 (C) 2000-2002 Arpad Gereoffy (see DOCS)

CPU: Advanced Micro Devices Athlon 4 PM Palomino/Athlon MP
Multiprocessor/Athlon XP eXtreme Performance (Family: 6, Stepping: 2)
SSE supported but disabled
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or
Reading config file /home/marco/.mplayer/config
Reading /home/marco/.mplayer/codecs.conf: 44 audio & 112 video codecs
Font /home/marco/.mplayer/font/font.desc loaded successfully! (206
Failed to open /dev/rtc: Permission denied (mplayer should be setuid
root or /dev/rtc should be readable by the user.)
Using usleep() timing
Unknown key 'BACKSPACE'
Can't open input config file /usr/local/etc/mplayer/input.conf : No such
file or directory
Falling back on default (hardcoded) input config

Playing VCD track 4
track 01:  adr=1  ctrl=4  format=2  00:02:00  mode: 11
track 02:  adr=1  ctrl=4  format=2  00:08:02  mode: 11
track 03:  adr=1  ctrl=4  format=2  18:34:17  mode: 11
track 04:  adr=1  ctrl=4  format=2  37:01:28  mode: 11
track 05:  adr=1  ctrl=4  format=2  55:33:14  mode: 11
OGG file format detected.
Opening audio decoder: [libvorbis] Ogg/Vorbis audio decoder
AUDIO: 48000 Hz, 1 ch, 16 bit (0x10), ratio: 10000->96000 (80,0 kbit)
Selected audio codec: [vorbis] afm:libvorbis (OggVorbis Audio Decoder)
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local
Disabling DPMS
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
AO: [oss] 48000Hz 1ch Signed 16-bit (Little-Endian)
Building audio filter chain for 48000Hz/1ch/16bit ->
Start playing...
This file was encoded with libavcodec build 4639
VDec: vo config request - 480 x 360 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1,33:1 - prescaling to correct movie aspect.
VO: [xv] 480x360 => 480x360 Planar YV12
Successfully enabled DPMS,077 ct:  0,173   58/ 58   6%  5%  6,7% 0 0 0%

Exiting... (Quit)

Regards,  Marco Gigante

More information about the MPlayer-users mailing list