[MPlayer-users] WMV videos (all?) crash on my system, MPlayer CVS 2003.08.24

zimon@iki.fi zimon at niksula.hut.fi
Tue Aug 26 01:54:19 CEST 2003

All WMV-videos seem to crash on my RH9 (PentiumPro) system with
MPlayer CVS version taken 2003.08.24 from MPlayerHQs. I also have
fresh win32codecs.tar.bz intalled from MPHQ.

Any idea why it seems to crash inside this MS DLL (wmv8ds32.ax)?
Native lavcodecs seem to work ok, this far.

For example this file:
< http://www.appelsiini.net/~tuupola/misc/AC130_GunshipMed.wmv >

I run MPlayer under gdb, tried to play the WMV file and got this:

Script started on Tue 26 Aug 2003 02:30:29 AM EEST
[zimon at adc mencoder-tests]$ ls
AC130_GunshipMed.wmv  typescript
[zimon at adc mencoder-tests]$ gdb mplayer
GNU gdb Red Hat Linux (5.3post-0.20021129.18rh)
Copyright 2003 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(no debugging symbols found)...
(gdb) add-symbol-file /usr/lib/debug/usr/bin/mplayer.debug
add symbol table from file "/usr/lib/debug/usr/bin/mplayer.debug" at
(y or n) y
Reading symbols from /usr/lib/debug/usr/bin/mplayer.debug...done.
(gdb) directory /usr/src/debug/MPlayer-20030824/
Source directories searched: /usr/src/debug/MPlayer-20030824:$cdir:$cwd
(gdb) run -v AC130_GunshipMed.wmv
Starting program: /usr/bin/mplayer -v AC130_GunshipMed.wmv
[New Thread 1082060672 (LWP 2474)]
Using GNU internationalization
Original domain: messages
Current dirname: /usr/share/locale
MPlayer dev-CVS--3.2.2 (C) 2000-2003 MPlayer Team
CPU: Intel PentiumPro (Family: 6, Stepping: 9)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 0 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions:
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/zimon/.mplayer/config
Reading /home/zimon/.mplayer/codecs.conf: Can't open '/home/zimon/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 60 audio & 150 video codecs
CommandLine: '-v' 'AC130_GunshipMed.wmv'
get_path('font/font.desc') -> '/home/zimon/.mplayer/font/font.desc'
font: can't open file: /home/zimon/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using X86 Optimized OnScreenDisplay
Failed to open /dev/rtc: Device or resource busy (mplayer should be setuid root
or /dev/rtc should be readable by the user.)
Using usleep() timing
get_path('input.conf') -> '/home/zimon/.mplayer/input.conf'
Parsing input config file /etc/mplayer/input.conf
Input config file /etc/mplayer/input.conf parsed: 56 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such device
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
get_path('AC130_GunshipMed.wmv.conf') -> '/home/zimon/.mplayer/AC130_GunshipMed.wmv.conf'
Playing AC130_GunshipMed.wmv
Not an URL!
[file] File size is 5787019 bytes
STREAM: [file] AC130_GunshipMed.wmv
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
CACHE_PRE_INIT: 0 [0] 0  pre:0  eof:0
Cache fill: 11.82% (991232 bytes)    Checking for YUV4MPEG2
DEMUXER: freeing demuxer at 0x8464e98
ASF: packets: 4818  flags: 2  max_packet_size: 1200  min_packet_size: 1200  max_bitrate: 103149  preroll: 3000
stream type: guid_audio_stream
stream concealment: guid_audio_conceal_interleave
type: 28 bytes,  stream: 8 bytes  ID: 1
unk1: 0  unk2: 3AFFC14
==> Found audio stream: 1
======= WAVE Format =======
Format Tag: 353 (0x161)
Channels: 1
Samplerate: 16000
avg byte/sec: 2000
Block align: 640
bits/sample: 16
cbSize: 10
Unknown extra header dump: [0] [22] [0] [0] [e] [0] [80] [7] [0] [0]
ASF: audio scrambling: 1 x 1 x 640
stream type: guid_video_stream
stream concealment: unknown guid 0057fb20-555b-cf11-a8fd00805f5c442b
type: 55 bytes,  stream: 0 bytes  ID: 2
unk1: 0  unk2: F29600
==> Found video stream: 2
======= VIDEO Format ======
  biSize 44
  biWidth 320
  biHeight 240
  biPlanes 1
  biBitCount 24
  biCompression 844516695='WMV2'
  biSizeImage 0
Unknown extra header dump: [78] [50] [fc] [80]
============ ASF Stream group == START ===
 object size = 38
 stream count=[0x2][2]
   stream id=[0x1][1]
   max bitrate=[0x43f2][17394]
   stream id=[0x2][2]
   max bitrate=[0x14efb][85755]
============ ASF Stream group == END ===
 Title: AC-130 Gunship Targeting Video, Afghanistan
 Author: Curt
 Copyright: 12/6/2002
 Rating: PG
Found movie at 0xA6D - 0x5842CD
ASF: 1 audio and 1 video streams found
Invalid plen type! assuming plen=0
Auto-selected ASF video ID = 2
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
VIDEO:  [WMV2]  320x240  24bpp
ASF: Searching for audio stream (id:1).
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Auto-selected ASF audio ID = 1
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
Invalid plen type! assuming plen=0
[V] filefmt:6  fourcc:0x32564D57  size:320x240  fps:1000.00  ftime:=0.0010
Clip info:
 name: AC-130 Gunship Targeting Video, Afghanistan
 author: Curt
 copyright: 12/6/2002
get_path('sub/') -> '/home/zimon/.mplayer/sub/'
get_path('default.sub') -> '/home/zimon/.mplayer/default.sub'
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
dec_audio: Allocating 131072 + 65536 = 196608 bytes for output buffer
FFmpeg's libavcodec audio codec
INFO: libavcodec init OK!
AUDIO: 16000 Hz, 1 ch, 16 bit (0x10), ratio: 2000->32000 (16.0 kbit)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (ffmpeg))
X11 opening display: :0.0
vo: X11 color mask:  FFFFFF  (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports layers.
[x11] Using workaround for Metacity bugs.
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
Opening video decoder: [dshow] DirectShow video codecs
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1082060672 (LWP 2474)]
0x0002ffe2 in ?? ()
(gdb) bt
#0  0x0002ffe2 in ?? ()
#1  0x0811bebb in MODULE_InitDll (wm=0x0, type=0, lpReserved=0x0)
    at module.c:153
#2  0x0811bf8e in MODULE_DllProcessAttach (wm=0x1c400000, lpReserved=0x0)
    at module.c:249
#3  0x0811c18b in LoadLibraryExA (libname=0x83fca38 "wmv8ds32.ax", hfile=0,
    flags=0) at module.c:412
#4  0x0811c4b1 in LoadLibraryA (libname=0x0) at module.c:495
#5  0x08129ff3 in DS_FilterCreate (dllname=0x83fca38 "wmv8ds32.ax", id=0x0,
    in_fmt=0x849ac84, out_fmt=0x0) at DS_Filter.c:145
#6  0x0812a790 in DS_VideoDecoder_Open (dllname=0x83fca38 "wmv8ds32.ax",
    guid=0x0, format=0x849accc, flip=0, maxauto=0) at DS_VideoDecoder.c:179
#7  0x080d1d0f in init (sh=0x84657a8) at vd_dshow.c:53
#8  0x080cab66 in init_video (sh_video=0x84657a8, codecname=0x0, vfm=0x0,
    status=1) at dec_video.c:232
#9  0x080cadff in init_best_video_codec (sh_video=0x84657a8,
    video_codec_list=0xbfffcbf4, video_fm_list=0x0) at dec_video.c:278
#10 0x0806eabe in main (argc=3, argv=0xbfffdf94) at mplayer.c:1693
#11 0x420156a4 in __libc_start_main () from /lib/tls/libc.so.6
(gdb) list module.c:153
148     module.c: No such file or directory.
        in module.c
(gdb) quit
The program is running.  Exit anyway? (y or n) y
[zimon at adc mencoder-tests]$ locate wmv8ds32.ax
[zimon at adc mencoder-tests]$ rpm -qf `locate wmv8ds32.ax`
[zimon at adc zimon]$ file `locate wmv8ds32.ax`
/usr/lib/win32/wmv8ds32.ax: MS Windows PE Intel 80386 GUI DLL not relocatable
[zimon at adc mencoder-tests]$ exit

Script done on Tue 26 Aug 2003 02:34:27 AM EEST

// z

More information about the MPlayer-users mailing list