[MPlayer-users] Process X using too much CPU

Dirk dirk2 at wor.net
Tue Apr 29 06:33:37 CEST 2003

Jonathan Rogers wrote:

 > [Automatic answer: RTFM (read DOCS, FAQ), also read DOCS/bugreports.html]
 > Dirk wrote:
 >> [Automatic answer: RTFM (read DOCS, FAQ), also read 
 >> Hello,
 >> when playing videos using "mplayer -vo xv" the process X uses about
 >> 50% CPU (on an athlon XP 1800+) and the video quality is poor.
 >> This did not happen before I upgraded my SuSE 8.0 to 8.2. Before, the
 >> total CPU usage was less than 5%. I was using -vo xv because this was
 >> the only -vo driver to use so litte CPU and giving such a good video 
- no drops
 >> no hangs - even when recoring withh mencoder at the same time and
 >> the total CPU usage was at 95%.
 > The main advantage of Xvideo (xv) is that it allows the hardware to
 >do colorspace conversion and scaling (for fullscreen). Probably
 >almost all video cards these days do have that capability, but not
 >all XFree drivers know about it. I use the NVidia binary driver for
 >my Vanta and xv works quite well. If I used the driver that comes
 >with XFree for Nvidia cards, the card wouldn't be doing conversions
 >in hardware, so I suspect it is a driver issue for you. Was it the
 >same video hardware when there was little CPU usage?
I also suspected a driver issue, but I already posted in the mailing
list xfree86 at XFree86.Org and the developer if the sis driver told me
that it worked for him quite good. So I think it isn't a driver
bug. Or shoudn't I?

The video hardware hasn't changed, I have got a SiS 650 chipset with
SiS 301 for TVOut in a "Shuttle SS40" box. I only have a TV connected
to TVOut but no monitor - this box is my "personal video disk

Any idea?

What is the X process doing? The answer could help me to identify the

I have been thinking much about what has changed since it was working
so well. Well, I did a Update from SuSE 8.0 to 8.2... Could be many

I already tried to:

- switche back to my old kernel (2.4.18 compiled by myself)
- switche off acpi (kernel option acpi=off)
- tried my old, working XF86Config
- changed the colour depth from 16 to 24 bit (resolution is 800x600)

Any other hints?

Thank you very much,


More information about the MPlayer-users mailing list