[MPlayer-users] Signal 11, bug in mcdvd_32.dll in w32codecs-0.90-2

Marcel Sundoo Bjerkmann marcel at broadpark.no
Mon Apr 28 06:04:10 CEST 2003

Hi there!. I'm using MPlayer with SuSE Linux 8.1, X 4.2. Got a sig 11 while 
trying to play a movie. Downloaded latest CVS MPlayer-20030427, compiled 
sucsessfully and tried again, without result :(
I figured it had to do with the w32codecs, and so I dloaded the lastest 
version 0.90-2. Installed and tried again, but nope, no resullts :(
My theory is that the w32codecs are buggy with my movie..

Do you have any suggestions to my problem?
When will the next release of the the w32codecs be?

Help will be greatly appreciated ;)

Here's my outut when i tried to play the movie:

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/marcel/.mplayer/config
Reading /home/marcel/.mplayer/codecs.conf: can't open 
'/home/marcel/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 49 audio & 130 video codecs
font: can't open file: /home/marcel/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system 
startup scripts.
Using usleep() timing
Can't open input config file /home/marcel/.mplayer/input.conf : No such file 
or directory
Input config file /etc/mplayer/input.conf parsed : 50 binds

Playing Lilja.4.ever.DivX.swedish.perfect.quality.avi
Cache fill:  0.00% (0 bytes)    AVI file format detected.
VIDEO:  [CDVC]  720x576  24bpp  25.00 fps  28800.1 kbps (3515.6 kbyte/s)
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 32000 Hz, 2 ch, 16 bit (0x10), ratio: 128000->128000 (1024.0 kbit)
Selected audio codec: [pcm] afm:pcm (Uncompressed PCM)
vo: X11 running at 1600x1200 with depth 16 and 16 bpp (":0" => local display)
Opening video decoder: [vfw] Win32/VfW video codecs
Loading codec DLL: 'mcdvd_32.dll'
Loaded DLL driver mcdvd_32.dll
VDec: vo config request - 720 x 576 (preferred csp: Packed YUY2)
[PP] Using codec's postprocessing, max q = 9.
VDec: using Packed YUY2 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 720x576 => 720x576 Packed YUY2
Selected video codec: [mcdv] vfm:vfw (MainConcept DV Codec)
Checking audio filter chain for 32000Hz/2ch/16bit -> 32000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 32000 hz, little endian signed int
AF_pre: 32000Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 32000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 32000Hz/2ch/16bit -> 32000Hz/2ch/16bit...
Starting playback...
A:   0.2 V:   0.0 A-V:  0.181 ct:  0.004    2/  2   0%  0%  0.0% 0 0 19%

MPlayer interrupted by signal 11 in module: decode_video
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. For details, see DOCS/bugreports.html#crash.b.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc
  version. If you think it's MPlayer's fault, please read DOCS/bugreports.html
  and follow the instructions there. We can't and won't help unless you 
  this information when reporting a possible bug.
Total Unfree 4952 bytes cnt 2 [(nil),0]

More information about the MPlayer-users mailing list