[MPlayer-users] mplayer and alsa9/dmix

Florian Schmidt mista.tapas at gmx.net
Mon Apr 21 01:48:30 CEST 2003

On Sun, 20 Apr 2003 16:29:47 -0700
Corey Hickey <bugfood-ml at fatooh.org> wrote:

> Hmm, I made your change to cvs (updated a few minutes ago). mplayer
> -ao alsa9:dmix and -ao alsa9:mixed (copied from your asoundrc to mine)
> both have the same problem, but don't fail setting period size like
> they did before.
> When I run mplayer on a 48000Hz wav file, it plays about half a second
> of audio and appears to hang. I have to use CTRL-C to quit.
> If I play a video with 48000Hz mp3 sound, then mplayer also appears to
> hang, but actually I can still operate mplayer - every time I seek or
> unpause, it only plays half a second, then stops.
> Mplayer -ao alsa9 still works just fine, so it doesn't look like
> anything else got broken. Out of curiosity, what is the period_size
> reported by aplay somefile.wav -v ? Mine is 4096, and 6000 when I
> specify -Ddmix. I don't know if that matters.

Thanks for the feedback. I'm guilty, though,  of rushing that fix out. I
tried around some more and have come up with a fix which should play
almost every movie. But i would like to contact the driver developer
first, cause i have some issues with the code.

I send it to you per email (i don't quite know how to create a correct
patch) for testing..

mista.tapas at gmx.net
sound clips - http://www.arted.biz/mista.tapas

More information about the MPlayer-users mailing list