[MPlayer-users] Solved: qt audio problem

David Shochat shochat at acm.org
Sun Apr 13 14:45:38 CEST 2003

Problem is solved. I discovered I had a /usr/local/lib/win32. I thought 
it would ignore that and take /usr/lib/win32 as the default. Perhaps so 
at runtime, but maybe not at build time. So I renamed that to get it out 
of the picture (problem still there at this point). So then I 
re-configured and re-built (after renaming /usr/local/lib/win32).

Now it works. So my theory is that during the build process, something 
looked at /usr/local/lib/win32 and decided I did not have the necessary 
pieces (in fact there was no qt stuff in there).

Suggestion: If the user says --enable-qtx-codecs and it looks like they 
are missing, fail configure with an appropriate error message. Also, if 
/usr/lib/win32 is supposed to be the default and the user does not 
override it, then ignore /usr/local/lib/win32 during the build as well 
as at runtime.

Sascha Sommer wrote:

> The following lines are missing in you log:
>### Searching for QuickTime plugins (*.qtx) at /usr/lib/win32...
>### FindNext: QuickTimeEssentials.qtx
>### FindNext: QuickTimeInternetExtras.qtx
>So please check if you really have those qtx files in /usr/lib/win32
The 1st of those 3 lines is the most interesting. Why was it not 
searching for them?

More information about the MPlayer-users mailing list