[MPlayer-users] problem with subtitles

Tathagata Banerjee tathagatabanerjee at gmx.net
Wed Apr 9 06:42:37 CEST 2003

i wanted to create a unified avi of video and subtitles. i tried

$ mplayer -dvd 1 -slang en -dumpstream -dumpfile rashomon.vob

but the resulting file did not contain subs. so next i tried

$ mplayer -dvd 1 -slang en -dumpsub

this exited with the message:

demux: File doesn't contain the selected audio or video stream.
core dumped ;)

that second line is of course a joke, as someone pointed out on this
list a few days ago.

then i tried 

$ mencoder -dvd 1 -slang en -vobsubout rashomon -vobsuboutid en -ovc \
copy -oac copy -o /dev/null

i got two files called rashomon.sub and rashomon.idx. but mplayer
doesn't seem to be able to use them. i tried playing rashomon.vob with
"-sub rashomon.sub" and without it, but there are no subtitles. am i
making a silly mistake?

my second problem is, i want to create a single avi that will contain
audio,video and subtitles. how do i do it from rashomon.* ?

thanks in advance.

- t.

cogito, ergo es.

More information about the MPlayer-users mailing list