[MPlayer-users] Bugs, questions

Attila Kinali kinali at gmx.net
Sat Mar 23 19:25:01 CET 2002

On Sat, 23 Mar 2002 17:12:35 +0100 (MET)
Bogdán Zaválnij <bogdan at renyi.hu> wrote:

> OK, let's do it your way.. (althought personally I think it would be too
> mutch to read..)

I rather like to read too much than trying to guess what system/error
a user has. Beside, if it's really not needed i can skipp it :)
> * (--) PCI:*(1:0:0) NVidia Riva TNT rev 4, Mem @ 0xe4000000/24, 0xe6000000/24

> * Multimedia audio controller: ESS Technology ES1969 Solo-1 Audiodrive
>   (rev 01)
> * I have no configure.log.. (??)
> judit ~/targz/mplayer/MPlayer-20020321 > find . -name configure.log
> judit ~/targz/mplayer/MPlayer-20020321 > 

that's strange

> * config.h, config.mak, libvo/config.mak attached..
> That's all, yes?
> the problem is described in the first part..
> the CVS version 20020320 and 21 and 22 crashes while compileing.
> from that time I could perfectly compile version 20020315 althought!
> the make error again:
> libmpdemux/libmpdemux.a(demux_ogg.o): In function `demux_ogg_add_packet':
> demux_ogg.o(.text+0x9b): undefined reference to `vorbis_packet_blocksize'
> collect2: ld returned 1 exit status
> make: *** [mplayer] Error 1
ok, check your installation of vorbis (looks like something is missing)
man ldconfig
man ld.so.conf
tell ./configure where libvorbis and libogg is

> > 0.50 is half a year old. even 0.60 was removed from the webpage because
> > it's outdated.
> > 
> OK, ypu're right. (but you could see, I couldn't compile the newer
> versions..) anyway: the problem is absolutely there. I compiled versions
> 0.50, 0.60 and CVS code 20020315 ALL of them playing the file with the
> same speed (4-5% framedrop..), while the same movie plays OK in wondows on
> the same computer.

You are using sdl with X11 drivers, that's afaik the slowest possible
driver you can use. Even -vo x11 is faster. Try to get Xvideo support
for your card (dunno whether it's possible) or get a better graphic
card. Beside you have a system that is really at the lower end (so you need
to have a good card)

> My additional question was, why is the sound decoding using 50-60% of cpu
> time, while mpg123 uses only 4-6% while playing mp3 files.. (it is
> perhaps some sort of lame question, but there is still no word about it in
> the DOCS.)

Hmm.. should not...

> from the time my last bug report I compiled with NAS. I have two problems
> with that. first, that te "configure" did not recognised I have NAS
> installed (compiled from source, and installed by default values), only
> with the switch "--with-extraincdir=/usr/X11R6/include" where the audio
> header files are in the "audio/" directory.. is that normal??
> my second problem: the movie playing is VERY slow, and there is no sound
> playing on the NAS server. (only some very short sound appears after "fast
> forward" --- pressing the "->" button). mpg123 plays OK with the same
> server. I tried NAS 1.4.2, 1.5, 1.5a.

Dunno what's wrong here... never used nas
(btw: it's not a good idea to put to much between mplayer
and the sound card as the delay get's unpredictable)

			Attila Kinali

I am a moslem, i am a terrorist.

More information about the MPlayer-users mailing list