[MPlayer-users] Problem with xvidix and ATI Rage Mobility M3

Fabrice Boyrie fboyrie at ens-lyon.fr
Sun Mar 17 16:18:02 CET 2002

The xvidix driver doesn't work with my M3 card. When I try to play
a file, it doesn't display anything and use 100% of the CPU.

mplayer -v 1 -fs -vo xvidix albator84_13.avi >& bidou.log
MPlayer CVS-020315-06:00-2.95.3 (C) 2000-2002 Arpad Gereoffy (see DOCS!)

CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
CPU vendor name: GenuineIntel  max cpuid level: 2
CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Type: 6,
Stepping: 3)
Testing OS support for SSE... yes.
Testing OS support for SSE unmasked exceptions... yes.
Tests of OS support for SSE passed.
Compiled for x86 CPU with features: MMX MMX2 SSE
get_path('font/font.desc') -> '/home/fboyrie/.mplayer/font/font.desc'
Reading /home/fboyrie/.mplayer/codecs.conf: 29 audio & 79 video codecs
CommandLine: '-v' '1' '-fs' '-vo' 'xvidix' 'albator84_13.avi'
get_path('input.conf') -> '/home/fboyrie/.mplayer/input.conf'
Font /home/fboyrie/.mplayer/font/font.desc loaded successfully! (495
Using Linux's hardware RTC timing (1024Hz)
Joue 1
Parsing input config file /home/fboyrie/.mplayer/input.conf
Input config file /home/fboyrie/.mplayer/input.conf parsed : 49 binds
No vidix driver name provided, probing available ones!

MPlayer interrompu par le signal 2 dans le module: vobsub 
vidixlib: PROBING: /usr/local/lib/mplayer/vidix/genfb_vid.so
[genfb] probe
Error occured durint open: No such file or directory
vidixlib: PROBING: /usr/local/lib/mplayer/vidix/mga_crtc2_vid.so
[mga] probe
[mga] No supported cards found
vidixlib: PROBING: /usr/local/lib/mplayer/vidix/mga_vid.so
[mga] probe
[mga] No supported cards found
vidixlib: PROBING: /usr/local/lib/mplayer/vidix/nvidia_vid.so
[nvidia] probe
No chip found
vidixlib: PROBING: /usr/local/lib/mplayer/vidix/radeon_vid.so
Radeon_vid: Can't find chip
vidixlib: PROBING: /usr/local/lib/mplayer/vidix/rage128_vid.so
Rage128_vid: Can't find chip
vidixlib: PROBING: /usr/local/lib/mplayer/vidix/mach64_vid.so
[mach64] Found chip: Rage Mobility M3 AGP 2x
vidixlib: /usr/local/lib/mplayer/vidix/mach64_vid.so probed o'k
vidixlib: will use /usr/local/lib/mplayer/vidix/mach64_vid.so driver
vidixlib: Attempt to initialize driver at: 0x40017c08

NB: With an older version of mplayer (20020215) my card wasn't recognised
but I could impose
rage128_vid.so (this card is a laptop version of rage128 and not mach 64)
and it worked almost correctly. (When the video hadn't 4/3 format, not
part of display was left untouched except a back rectangle at the left
corner of the screen).
  I have tried to impose rage128_vid.so with 09/03/2002 version and it
badly frozen my
computer (reboot with SyRq s u b, then extinction of the computer because
display stay blank
after reboot). I haven't tried with the latest version, and I would prefer
don't try.

NB2: With -vo xv the video works perfectly

*                  All requested data                           *

* linux distribution
Mandrake "8.2" (8.1 updated with all packages of the future  8.2)
* kernel version:
Linux bidoubidou 2.4.18-rc4 #1 ven fév 22 16:57:45 CET 2002 i686 unknown
 * libc version:
-rwxr-xr-x    1 root     root      1275300 mar  7 23:45 /lib/libc-2.2.4.so
lrwxrwxrwx    1 root     root           13 mar 12 09:33 /lib/libc.so.6 ->
 * X version:   

XFree86 Version 4.2.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
        If the server is older than 6-12 months, or if your card is
        newer than the above date, look for a newer version before
        reporting problems.  (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.17-2mdksmp i686 [ELF] 
Module Loader present
* gcc and ld version:
gcc -v         
Reading specs from /divers/gcc/lib/gcc-lib/i686-pc-linux-gnu/2.95.3/specs
gcc version 2.95.3 20010315 (release)

(to avoid any troll about gcc version (but there is the same problem with
ld -v 
GNU ld version 20011121
* binutils version:
GNU assembler 20011121

* CPU info:
cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 696.982
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov
pat pse36 mmx fxsr sse
bogomips        : 1389.36

 * video card manufacturer and model   
(--) R128(0): Chipset: "ATI Rage 128 Mobility LF (AGP)" (ChipID = 0x4c46)
(**) R128(0): Using flat panel for display
(II) R128(0): Panel size: 1400x1050
(II) R128(0): Panel ID: IBM ITSX93    
(II) R128(0): Panel Type: Color, Single, TFT
(II) R128(0): Panel Interface: LVDS
(II) R128(0): PLL parameters: rf=2950 rd=65 min=12500
max=25000; xclk=10500
(--) Chipset ATI Rage 128 Mobility LF (AGP) found   (XFree86.0.log)
ATI Rage 128 Mobility: ATI|Rage Mobility M3 AGP 2x  (lspcidrake)
R128(0): VideoRAM: 16384 kByte (128-bit SDR SGRAM 1:1)
 * video driver type&version    
(II) ATI: ATI driver (version 6.4.7) for chipsets: ati, ativga
(gatos driver)
 * sound card type & driver 
 Crystal 4280/46xx + AC97 Audio, version 1.28.32, 21:43:44 Feb 24 2002
 cs46xx: Card found at 0xf0122000 and 0xf0000000, IRQ 9
 cs46xx: Thinkpad 600X/A20/T20 (1014:0153) at 0xf0122000/0xf0000000, IRQ 9
 ac97_codec: AC97 Audio codec, id: 0x4352:0x5914 (Cirrus Logic CS4297A rev
 Loading sound module (cs46xx) succeeded

(driver of kernel)

More information about the MPlayer-users mailing list