[MPlayer-users] Error loading "divxa32.acm" - AGAIN

clemenswaechter clemenswaechter at yahoo.com
Fri Mar 1 19:52:01 CET 2002

On Fri, 1 Mar 2002, Igor Evdokimov wrote:
> >Since version 0.50pre... and for 0.60 I have
> >the following result of loading AVI file after a little pause (1-2 sec.)
> >after string <Loading DLL: 'divxa32.acm'>:
> >-Detected audio codec: [divx] drv:4 (DivX audio (WMA))
> >-Loading DLL: 'divxa32.acm'
> >-MPlayer interrupted by signal 11 in module: init_audio_codec
> >This AVI is playing fine in mplayer0.18..., but new versions
> >does not want to play it, thougth Arpi says that it works well in latest
> versions.

Yes, I've got *exactly* the same problem.
Although I didn't get 0.5 to compile, since my g++ seems to be
misinstalled accoding to mailing list archives etc.
Mplayer 0.6 plays fine for me with most of the codecs... but some
fail. I guess its just the audio codecs.

Can you perhaps check if you do also have the problems only with
the audio codecs (but not with the video codecs)?

> and received some answers.
> I've tried almost all, except upgrading my system to LIBC version 2.2.x
> ...
> New version (0.60) coudn't help. Binutils 2.11.92 too.
> The problem is'nt solved yet.

I tinkered everywhere in my system, too. Nothing helped. 

> Together with Joergen Scheibengruber we decided that the problem is in
> LIBC version we use - 2.1.3 (rather in mplayer that conflicts with LIBC
> :-)

/me has got the same antique glibc. This _is_ probably the cause

> All people that are using 2.2.x LIBC versions runs DivX WMA audio in
> mplayer with success. But I don't want now to upgrade almost all packages
> in my system...

I am currently using a self-compiled LFS which I compiled according to
the instructions but not with the most recent files since I downloaded them
using a friends internet connection because the files are together all so
Now I have DSL too and I am now using the most recent packages and the
problem is gone....
So it seems that you have no other choice than updating.

> What can I do to help to correct this bug?

I guess that you can't correct this bug easily. But as a workaround
(please do not ban me / flame me, I know its not right, I've read the docs)
you could try to use a statically linked version which you compile on
a machine with a working glibc ( that is with a glibc version > 2.1.3).
This worked for me when I had problems with the c++ win32 loader and my
broken gcc install.
Anyways this is just a very ugly workaround, I admit. Also read the cons
of binary packages in the docs, there are various which you should also

> Sincerely, Igor.

On Fri, 1 Mar 2002, Arpi wrote:
> [Automatic answer: RTFM (read DOCS, FAQ), also read DOCS/bugreports.html]
> Hi,
> > What can I do to help to correct this bug?
> sending a full bugreport?

Well, I did that and sent it to you but never heared anything from you.
Not that it would matter to me since I will soon have my new LFS fully
and ready to use.
Btw: I sent that bug report on 26.12.01 and 27.12.01 ( since it did not
include everything etc)

> did you tried as root?

Doesn't help. It doesn't matter wheter its run as root or not.

It really seems to be the glibc....

With kind regards
Clemens Wächter

Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

More information about the MPlayer-users mailing list