[MPlayer-users] TV Viewing Problems

David Robertson lego at california.com
Sat Jul 20 08:04:02 CEST 2002

judging from the command string i hope you can see ive tried
 maybe a
hundred possible variations, some logical, some far-fetched.
ive been working on this for 30 hrs straight and read every
could find. and configured and checked over everthing many
so, ive tried, please throw me a few scraps of suggestions for
 the next move.
all the posts that i could find in the archive (only about 25)
 that concerned TV
capture/encoding seemed to end without resolution. eithr the
 poster's died or
gave up..
I am closer to the former fate. XAWTV works great AND MPLAYER
 plays avi's beautifully  my v4l drivers and other
areas must be in order.
i have tried outfmt: yv12, rgb24, rgb32. different geometries.
 i tried different
-vo options, different input options:"television" and "0". ive
 checked, read
and changed permissions of the ~/.mplayer/codec.conf file and
related to it that i could think of. ive installed every
 library listed without error and then some, compiled for TV
 support. overcame the gcc version with skill and ease
ive done more than i can write or remember here.

the things that i are concerned about and seem to show up in
 EVERY variation and attempt is "TUNER ISN'T CAPABLE TO SET
 NORM!" <--why?? and the dreaded "VDecoder init failed :(
Can't find codec matching selected -vo and video format
 0x32315659 !" <-- ive tried everything?

PLEASE guide me. tell me what you need to know more. what i am
 missing, what to do next, tell me anything at all.


PS: from what i read, IF i get this to display tv, is it still
 true that i will not be able to encode sound?

[lego at m dev]$ mplayer -tv
 -vo xv

MPlayer 0.90pre5-3.0.4 (C) 2000-2002 Arpad Gereoffy (see DOCS!)

CPU: Advanced Micro Devices Duron SF Spitfire (Family: 6,
 Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

Reading /home/lego/.mplayer/codecs.conf: 34 audio & 94 video
Can't load font bitmap: iso-8859-1-a.raw
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error: Permission denied
Using usleep() timing
Can't open input config file /home/lego/.mplayer/input.conf :
 No such file or
Falling back on default (hardcoded) input config

Playing TV channel 9
Selected driver: v4l
 name: Video 4 Linux input
 author: Alex Beregszaszi <alex at naxine.org>
 comment: under development
Selected device: BT878(Pinnacle PCTV Studio/Ra)
 Capabilites: capture tuner overlay clipping frameram scales

Capabilites: capture tuner overlay clipping frameram scales
 Device type: 235
 Supported sizes: 48x32 => 924x576
 Inputs: 3
  0: Television: tuner audio tv camera  (tuner:1, norm:0)
  1: Composite1: audio camera  (tuner:0, norm:0)
  2: S-Video: audio camera  (tuner:0, norm:0)
 Audio devices: 1
ioctl dsp getfmt: 0
Supported formats: 18
ioctl dsp setfmt: 0
ioctl dsp stereo: 0 (req: 0)
ioctl dsp speed: 0
ioctl dsp trigger: 0
trigger: 1
ioctl dsp trigger: 0
ioctl dsp getblocksize: 0
blocksize: 2048
Requested width: 640
Requested height: 480
Using input 'Television'
Selected norm: ntsc
Tuner isn't capable to set norm!

Selected channel list: us-cable (including 133 channels)
Selected channel: 9 (freq: 187.250)
Current frequency: 2996 (187.250)
Cache fill:  0.00% (0 bytes)    Detected TV! ;-)
Output format: Planar YV12
fps: 25.000000, frametime: 0.040000
Output size: 640x480
palette: 15, depth: 12, bytesperline: 960
Picture values:
 Depth: 12, Palette: 15 (Format: Planar YV12)
 Brightness: 32768, Hue: 32768, Colour: 32512, Contrast: 27648
vo: X11 running at 800x600 with depth 24 and 32 bpp (":0.0" =>
 local display)
Opening video decoder: [raw] RAW Uncompressed Video
VDecoder init failed :(
Can't find codec matching selected -vo and video format
 0x32315659 !
*** Try to upgrade /home/lego/.mplayer/codecs.conf from
*** If it's still not OK, then read DOCS/codecs.html!

More information about the MPlayer-users mailing list