[MPlayer-users] Possible bug [FreeBSD 5.0-CURRENT]

Per-Arne Holtmon Akø perarneh at online.no
Tue Jul 2 23:31:02 CEST 2002

I just recently updated my local copy from the cvs, and no matter which
configure arguments I give, the binary I end up with will exit on signal
4, SIGILL. I have a dark suspicion that this might just be the
transgression to gcc 3.1 in 5.0-C that's making my life hard, but I'm
not sure. I updated my copy at around 2100-2200 GMT+1.

Anyway, here's the rest of the info, according to bugreports.html:

FreeBSD 5.0-CURRENT from 17th of May, 2002.

uname -a:
FreeBSD hikaru 5.0-CURRENT FreeBSD 5.0-CURRENT #1: Tue Jun 18 16:20:37 CEST 2002     vrak at hikaru:/usr/obj/usr/src/sys/hikaru-smp  i386

-r--r--r--   1 root     wheel     1390294 Jun 19 10:22 /usr/lib/libc.a
lrwxr-xr-x   1 root     wheel           9 Jun 19 10:22 /usr/lib/libc.so -> libc.so.5
-r--r--r--   1 root     wheel      572876 Sep 18  2001 /usr/lib/libc.so.4
-r--r--r--   1 root     wheel      699964 Jun 19 10:22 /usr/lib/libc.so.5

X version:
XFree86 Version 4.2.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 18 January 2002
        If the server is older than 6-12 months, or if your card is
        newer than the above date, look for a newer version before
        reporting problems.  (See http://www.XFree86.Org/)
Build Operating System: FreeBSD 5.0 i386 [ELF] 
Module Loader present

gcc version:
Using built-in specs.
Configured with: FreeBSD/i386 system compiler
Thread model: posix
gcc version 3.1 [FreeBSD] 20020509 (prerelease)

ld version:
GNU ld version 2.12.0 [FreeBSD] 2002-04-10

binutils version:
GNU assembler 2.12.0 [FreeBSD] 2002-04-10

I'm using the BlackBox vm. And I have Xinerama enabled, since I've got
two monitors. I'm using the built-in mga driver in X. The graphics card
is a Matrox G450 32MB. The soundcard is a SB Live! Value card, using the
pcm driver in FreeBSD. 

I could not find a configure.log, but I found the other files, and also
saved the output from gmake during the compile, and uploaded it to the
ftp specified. They should be available at

I also tried generating a core dump and debug it, but gdb spat some
non-sensical stuff at me, so I dropped that. If anyone are willing to
help me a bit, I can probably convince it, but I didn't bother now.

Other than this, there really is not much to say, save for the fact that
earlier today I had an older binary from an older kernel/world, which
still worked. I have no idea how old it was, but probably no more that
two or three weeks old, probably not that old either. It's the new
binary compiled with this new kernel/world that's making trouble.

vrak AKA Per-Arne Holtmon Akø
E-mail: perarneh at online.no
ICQ UIN: 9455554
HP: http://home.online.no/~perarneh/

More information about the MPlayer-users mailing list