[MPlayer-users] stripes in image with (x)mga and ffmpeg on G200

Diego Biurrun diego at biurrun.de
Mon Jan 28 01:42:03 CET 2002


First I would like to state how satisfied I am with mplayer.  It gives
me performance at least equal to Windows Media Player on my machine
and has just ditched my last reason to occasionally boot windows :-)
Thanks for your excellent work!

One problem remains, though.  I have a divx file that gets thin
horizontal black stripes in the right half of the screen when played
with "-vo (x)mga -vfm 5".  When played in fullscreen or with -vo xv or
-vo x11 or without -vfm 5 it runs fine but considerably slower.

I tried with latest CVS as well as 0.6, gcc 2.95-4 and 3.0.3, always
the same problem.

I have a K6-2 500 and a Matrox G200 AGP card with 8MB SGRAM.  I run X
4.1.0 with the Matrox 1.4.3 drivers, although I also tried the Xfree
builtin driver with the same result.  My soundcard is a Creative SB
Live! running the stock kernel drivers.

My distribution is an up to date Debian woody (testing) with custom
compiled kernel 2.4.17 and libc 2.2.4, gcc 2.95-4, as and ld

I have uploaded a dd'ed chunk of the avi and the text of this email to 

A friend of mine with a G400 could play the file with the same options
without problems, so this might be G200 specific.

Any help would be greatly appreciated, I will gladly provide more
information if necessary.  Below are the outputs of the mplayer -v run
as well as lspci -v and cat /proc/cpuinfo.
Thanks a lot

Diego Biurrun

silver:/var/tmp$ ./MPlayer-20020127/mplayer -v -vfm 5 -vo xmga stripes.avi 

MPlayer CVS-020127-06:00-3.0.3 (C) 2000-2002 Arpad Gereoffy (see DOCS!)

CPU vendor name: AuthenticAMD  max cpuid level: 1
CPU: Advanced Micro Devices K6-2 (Type: 5, Stepping: 12)
extended cpuid-level: 5
CPUflags: Type: 5 MMX: 1 MMX2: 0 3DNow: 1 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with features: MMX 3DNow
Reading /home/diego/.mplayer/codecs.conf: 17 audio & 37 video codecs
CommandLine: '-v' '-vfm' '5' '-vo' 'xmga' 'stripes.avi'
get_path('font/font.desc') -> '/home/diego/.mplayer/font/font.desc'
font: can't open file: /home/diego/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init: open: Permission denied
Using usleep() timing
Playing stripes.avi
Not an URL!
File size is 1048576 bytes
Detected AVI file format!
======= AVI Header =======
us/frame: 41708  (fps=23.976)
max bytes/sec: 622692
padding: 0
MainAVIHeader.dwFlags: (2064) HAS_INDEX TRUST_CKTYPE
frames  total: 110815   initial: 1
streams: 2
Suggested BufferSize: 91134
Size:  768 x 320
==> Found video stream: 0
======= STREAM Header =======
Type: vids   FCC: div3 (33766964)
Flags: 0
Priority: 0   Language: 0
InitialFrames: 0
Rate: 239760/10000 = 23.976
Start: 0   Len: 110814
Suggested BufferSize: 91134
Quality 10000
Sample size: 0
found 'bih', 40 bytes of 40
======= VIDEO Format ======
  biSize 40
  biWidth 768
  biHeight 320
  biPlanes 1
  biBitCount 24
  biCompression 861292868='DIV3'
  biSizeImage 737280
Regenerating keyframe table for DIVX 3 video
==> Found audio stream: 1
======= STREAM Header =======
Type: auds   FCC:  (0)
Flags: 0
Priority: 0   Language: 0
InitialFrames: 1
Rate: 24000/1 = 24000.000
Start: 0   Len: 110924929
Suggested BufferSize: 1002
Quality -1
Sample size: 1
found 'wf', 30 bytes of 20
======= WAVE Format =======
Format Tag: 85 (0x55)
Channels: 2
Samplerate: 48000
avg byte/sec: 24000
Block align: 1
bits/sample: 0
cbSize: 12
Found movie at 0x800 - 0x2A9C7130
stream_seek: WARNING! Can't seek to 0x2A9C7130 !
Auto-selected AVI video ID = 0
AVI: Searching for audio stream (id:-1)
Auto-selected AVI audio ID = 1
XXX initial  v_pts=0.000  a_pos=0 (0.000) 
AVI video length=-109878401
VIDEO:  [DIV3]  768x320  24bpp  23.98 fps  -190.2 kbps (-23.2 kbyte/s)
[V] filefmt:3  fourcc:0x33564944  size:768x320  fps:23.98  ftime:=0.0417
get_path('sub/') -> '/home/diego/.mplayer/sub/'
Detected audio codec: [mp3] drv:1 (MPEG layer-2, layer-3)
Initializing audio codec...
dec_audio: Allocating 4608 + 65536 = 70144 bytes for output buffer
CPU vendor name: AuthenticAMD  max cpuid level: 1
CPU: Advanced Micro Devices K6-2 (Type: 5, Stepping: 12)
extended cpuid-level: 5
mp3lib: made decode tables with MMX optimization
init layer2&3 finished, tables done
mp3lib: using 3DNow! optimized decore!
MPEG 1.0, Layer III, 48000 Hz 192 kbit Joint-Stereo, BPF: 576
Channels: 2, copyright: Yes, original: Yes, CRC: No, emphasis: 0
AUDIO: srate=48000  chans=2  bps=2  sfmt=0x10  ratio: 24000->192000
Trying to force video codec driver family 5 ...
Detected video codec: [ffdivx] drv:5 prio:0 (FFmpeg DivX ;-) (MS MPEG-4 v3))
FFmpeg's libavcodec video codec
libavcodec: CPU flags: mmx 3dnow
INFO: libavcodec init OK!
Movie-Aspect is undefined - no prescaling applied.
VO: [xmga] 768x320 => 768x320 Planar YV12 
VO: Description: X11 (Matrox G200/G400 overlay in window using /dev/mga_vid)
VO: Author: Zoltan Ponekker <pontscho at makacs.poliod.hu>
vo: X11 color mask:  FFFF  (R:F800 G:7E0 B:1F)
vo: X11 running at 1152x864 with depth 16 and 16 bits/pixel (":0" => local display)
[xmga] dcx: 107 dcy: 305 dx: 0 dy: 0 dw: 768 dh: 320
[xmga] dcx: 107 dcy: 305 dx: 0 dy: 0 dw: 768 dh: 320
INFO: Video OUT driver init OK!
AO: [oss] 48000Hz Stereo Signed 16-bit (Little-Endian)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
ao2: 48000 Hz  2 chans  Signed 16-bit (Little-Endian)
audio_setup: using '/dev/dsp' dsp device
audio_setup: sample format: Signed 16-bit (Little-Endian) (requested: Signed 16-bit (Little-Endian))
audio_setup: using 2 channels (requested: 2)
audio_setup: using 48000 Hz samplerate (requested: 48000)
audio_setup: frags:  16/16  (4096 bytes/frag)  free:  65536
Start playing...
[xmga] dcx: 107 dcy: 305 dx: 0 dy: 0 dw: 768 dh: 320
ds_fill_buffer: EOF reached (stream: audio)  /174  25% 38%  3.1% 0 0 0%

Broken frame at 0x2C32E                                                  
Error while decoding frame!08 ct:  0.078  181/181  25% 38%  3.2% 0 0 0%
ds_fill_buffer: EOF reached (stream: video)  /182  25% 37%  3.1% 0 0 0%
EOF code: 1  
vo: uninit!
*** free_stream() called ***

Exiting... (End of file)
max framesize was 41187 bytes

silver:/var/tmp$ /sbin/lspci -v
00:00.0 Host bridge: Acer Laboratories Inc. [ALi] M1541 (rev 04)
	Subsystem: Acer Laboratories Inc. [ALi] ALI M1541 Aladdin V/V+ AGP System Controller
	Flags: bus master, slow devsel, latency 64
	Memory at e0000000 (32-bit, non-prefetchable) [size=64M]
	Capabilities: <available only to root>

00:01.0 PCI bridge: Acer Laboratories Inc. [ALi] M5243 (rev 04) (prog-if 00 [Normal decode])
	Flags: bus master, slow devsel, latency 64
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
	Memory behind bridge: df000000-dfffffff
	Prefetchable memory behind bridge: e6f00000-e7ffffff

00:02.0 USB Controller: Acer Laboratories Inc. [ALi] M5237 USB (rev 03) (prog-if 10 [OHCI])
	Flags: bus master, medium devsel, latency 0, IRQ 9
	Memory at de800000 (32-bit, non-prefetchable) [size=4K]

00:03.0 Bridge: Acer Laboratories Inc. [ALi] M7101 PMU
	Subsystem: Acer Laboratories Inc. [ALi] ALI M7101 Power Management Controller
	Flags: medium devsel

00:07.0 ISA bridge: Acer Laboratories Inc. [ALi] M1533 PCI to ISA Bridge [Aladdin IV] (rev c3)
	Flags: bus master, medium devsel, latency 0

00:09.0 Ethernet controller: 3Com Corporation 3c905C-TX [Fast Etherlink] (rev 74)
	Subsystem: 3Com Corporation 3C905C-TX Fast Etherlink for PC Management NIC
	Flags: bus master, medium devsel, latency 32, IRQ 5
	I/O ports at d800 [size=128]
	Memory at de000000 (32-bit, non-prefetchable) [size=128]
	Expansion ROM at <unassigned> [disabled] [size=128K]
	Capabilities: <available only to root>

00:0b.0 SCSI storage controller: LSI Logic / Symbios Logic (formerly NCR) 53c875 (rev 03)
	Flags: bus master, medium devsel, latency 72, IRQ 10
	I/O ports at d400 [size=256]
	Memory at dd800000 (32-bit, non-prefetchable) [size=256]
	Memory at dd000000 (32-bit, non-prefetchable) [size=4K]
	Expansion ROM at <unassigned> [disabled] [size=128K]

00:0d.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
	Subsystem: Creative Labs: Unknown device 8061
	Flags: bus master, medium devsel, latency 32, IRQ 5
	I/O ports at d000 [size=32]
	Capabilities: <available only to root>

00:0d.1 Input device controller: Creative Labs SB Live! (rev 07)
	Subsystem: Creative Labs Gameport Joystick
	Flags: bus master, medium devsel, latency 32
	I/O ports at b800 [size=8]
	Capabilities: <available only to root>

00:0f.0 IDE interface: Acer Laboratories Inc. [ALi] M5229 IDE (rev c1) (prog-if 8a [Master SecP PriP])
	Flags: bus master, medium devsel, latency 32
	I/O ports at b400 [size=16]

01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200 AGP (rev 01) (prog-if 00 [VGA])
	Subsystem: Matrox Graphics, Inc. Millennium G200 AGP
	Flags: bus master, medium devsel, latency 64, IRQ 11
	Memory at e7000000 (32-bit, prefetchable) [size=16M]
	Memory at df800000 (32-bit, non-prefetchable) [size=16K]
	Memory at df000000 (32-bit, non-prefetchable) [size=8M]
	Expansion ROM at e6ff0000 [disabled] [size=64K]
	Capabilities: <available only to root>

silver:/var/tmp$ cat /proc/cpuinfo 
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 5
model		: 8
model name	: AMD-K6(tm) 3D processor
stepping	: 12
cpu MHz		: 501.157
cache size	: 64 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr mce cx8 pge mmx syscall 3dnow k6_mtrr
bogomips	: 999.42

More information about the MPlayer-users mailing list