[MPlayer-users] No DVD Support and DXR3 Compiling Problems

John john at kg4kng.net
Mon Jan 21 19:22:02 CET 2002

Intel PIII 550mhz
Redhat 7.2
GeForce 256
Hollywood + DXR3
GCC 2.95.3

I have two unrelated problems when trying to compile MPlayer.  The first is
the configuration script does not find libdvdread or libdvdcss related
I have installed libdvdcss 0.0.3 and libdvdread 0.9.2 as laid out in the
howto for installing MPlayer.  Everything went well.  When running the
MPlayer configure it does not detect dvd support though.  Looking at the
configure.log it says the 4 .h files needed were not found.  I have searched
my system and they are there in /usr/local/include/dvdread.  I have edit
/etc/ld.so.conf, created /dev/dvd exists, and anything else I could think of
to get it to find dvd, but to no avail.  So I decided I would give up and
just force configure with DVD support since I knew I had it.
But....Compilation problems with DXR3 cropped up.
When I try to compile with DXR3 support enabled it would error like so:

ao_dxr3.c: In function `play':
ao_dxr3.c:263: `EM8300_IOCTL_AUDIO_SETPTS' undeclared (first use in this
ao_dxr3.c:263: (Each undeclared identifier is reported only once
ao_dxr3.c:263: for each function it appears in.)
make[1]: *** [ao_dxr3.o] Error 1
make[1]: Leaving directory `/home/download/MPlayer-0.60/libao2'
make: *** [libao2/libao2.a] Error 2

After looking at the file it turns out the funtion that it errored on seems
pretty useless so I commented it out and recompiled.  This time it failed on
another DXR3 file and I decide to turn to the mailing list archieves.  It
seems a patch was put out (by David Holmes I believe) to correct some of the
DXR3 issues.  I found it and tried to apply it but the patch seemed to have
various formatting issues, problably due to being emailed, archieved, and
cut and pasted to a file by myself.  I am assuming this patch, if I get it
with the correct formatting, will solve my DXR3 compiling issues.  Or do I
have a different problem.
Other information:
For both these problems I have tried the newest full release and the CVS and
both exhibited the same problems.  Also, I installed Xine just to test to
see if my DXR3 was set up and working fine and it is so I am assuming
problems are not my hardware or my computer in general but rather MPlayer
Thanks for any help you can provide on either issue!

More information about the MPlayer-users mailing list