[MPlayer-users] No image with tv unless outfmt=uyvy

watsondk at pobox.com watsondk at pobox.com
Sat Jan 12 07:06:02 CET 2002

Hash: SHA1

Yes really, the only way I have been able to get a picture using mplayer
with my v4l capture/tuner is to set the outfmt to uyvy

Even with this the colors are all wrong, its like a very green phto
negative. I have tried all combinations of the outfmt and -vc options, the
only picture I get is when using uyvy

All other v4l apps (xawtv, zapping etc) work well, as does mplayer with
everything other than the tv

The video source is a LD player with a PAL disk, I have tried other video
sources and that makes no difference.

My hardware/software is

Dell Dual Xeon, 1GB RAM, Haupaugge WinTVgo card, hardware RAID 5 (140GB).

running RH7.1 with X4.10 (built from source), 2.4.17 kernel

the command line I am using is

mplayer -tv on:driver=v4l:input=1:norm=pal:width=640:height=480:outfmt=uyvy -vo xv

the output I get is :-

- ---------------------------------------------------------------------------

MPlayer 0.60-2.95.3 (C) 2000-2002 Arpad Gereoffy (see DOCS!)

CPU vendor name: GenuineIntel  max cpuid level: 2
CPU: Intel Celeron Covington/Pentium II Deschutes,Tonga/Pentium II Xeon
(Type: 6, Stepping: 3)
CPUflags: Type: 6 MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with features: MMX
Reading /root/.mplayer/codecs.conf: can't open
'/root/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/share/mplayer/codecs.conf: 26 audio & 70 video codecs
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using Linux's hardware RTC timing (1024Hz)
Selected driver: v4l
 name: Video 4 Linux input
 author: Alex Beregszaszi <alex at naxine.org>
 comment: under development
Selected device: BT878(Hauppauge (bt878))
 Capabilites: capture tuner overlay clipping frameram scales
 Device type: 235
 Supported sizes: 48x32 => 924x576
 Inputs: 4
  0: Television: tuner audio tv camera  (tuner:1, norm:0)
  1: Composite1: audio camera  (tuner:0, norm:0)
  2: S-Video: audio camera  (tuner:0, norm:0)
  3: Composite3: audio camera  (tuner:0, norm:0)
 Audio devices: 1
Requested width: 640
Requested height: 480
Using input 'Composite1'
Selected norm: pal
Selected input hasn't got a tuner!
palette: 7, depth: 16, bytesperline: 1280
Picture values:
 Depth: 16, Palette: 7 (Format: Packed UYVY)
 Brightness: 32768, Hue: 32768, Colour: 32512, Contrast: 27648
Detected TV! ;-)
Output format: Packed UYVY
fps: 25.000000, frametime: 0.040000
Output size: 640x480
[V] filefmt:9  fourcc:0x59565955  size:640x480  fps:25.00  ftime:=0.0400
Detected video codec: [rawuyvy] drv:8 prio:0 (RAW UYVY)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 640x480 => 640x480 Packed UYVY
vo: X11 running at 1280x1024 with depth 16 and 16 bits/pixel (":0.0" =>
local display)
Xvideo image format: 0x32595559 (YUY2) packed
Xvideo image format: 0x32315659 (YV12) planar
Xvideo image format: 0x30323449 (I420) planar
Xvideo image format: 0x59565955 (UYVY) packed
using Xvideo port 59 for hw scaling
[xv] dcx: 0 dcy: 0 dx: 0 dy: 0 dw: 640 dh: 480
Disabling DPMS
stat: 1
Audio: no sound!!!
Start playing...

- ----------------------------------------------------------------------------

BTW. Sound is the next thing to be worked on.

Any help/ideas most welcome


PGP key: www.ozetechnology.com/keys/watsondk.pgp

Version: PGP 6.5.8


More information about the MPlayer-users mailing list