[MPlayer-users] Problem with a MPEG2 File, mencoder & mplayer behave differently.

Munaut Sylvain tnt at 246tNt.com
Fri Jan 4 23:02:01 CET 2002


I've just joined the ML, so if it has always been discussed, i'm sorry.
But i've checked CVS version & Documentation and my problem is not

So here it is :

I have a MPEG2 file that i know is "faulty" ( so it can't be considered
as a bug since the file is not really ok ). It has been recorded with a
DVB card directly in MPEG. I know it's faulty because most player can't
read it correcty ( either awfull sound, no image, AV un sync ... ).
BUT  mplayer can read it perfectly ( and it's one of the only player to
do that ... i've tried several, under win & linux ).
But i'd like to convert it to DivX so i've tried to use mencoder ( as
soon as i've read that mplayer can do it i've tried it ! ) But with
mencoder, the output avi file has the same A-V sync problem that i have
with many other mpeg -> divx converter ( flaskMpeg MPEG2Avi x2Avi ... ).
The sync is AWFUL, at the start, it's synchro and at the end ( of a 25
min file, i can have up to 3 min of delay ... The video is 'late' ).

I've tried to find what exactly in the file, ( i've read the mpeg2 doc
about program stream, looked at the file ... ) but i haven't yet found
... May be some experts here can help me.

I include max info about what i have tried and my system info (following
my message).

May be you'll ask why i just don't throw the file away and try so hardly
to convert it ? It's just because what i recorded probably won't be on
tv again for one or two year  ....  ( for info, it's maybe studpid for
you but it's a manga episode of "cat's eye" )

Tanx for any help,
    Munaut Sylvain

1. System info :
 Slackware 8.0
 Kernel 2.4.16
 Libc 2.2.3 - ( compiled by 2.95.3 on a linux 2.4.4 )
 X Version 4.1.0
 gcc 2.95.3  20010315(release)

 2. Hardware info
  CPU info :
    processor       : 0
    vendor_id       : AuthenticAMD
    cpu family      : 6
    model           : 4
    model name      : AMD Athlon(tm) Processor
    stepping        : 2
    cpu MHz         : 706.302
    cache size      : 256 KB
    fdiv_bug        : no
    hlt_bug         : no
    f00f_bug        : no
    coma_bug        : no
    fpu             : yes
    fpu_exception   : yes
    cpuid level     : 1
    wp              : yes
    flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr
pge mca cmov pat pse36 mmx fxsr syscall  mmxext 3dnowext 3dnow
    bogomips        : 1409.02
 Video card : Asus V6800 DDR Deluxe  ( Geforce 256 DDR )
 Driver X11 nvidia 1.0-2313
 Sound card : SB Live! with emu10k1 driver of the kernel
 lspci -v attached ( lspci.txt )

3. Mplayer & Mencoder info
 In attachment, the log of the play of a small file ( cutted from the
complete mpeg file with dd )
 and the log of the encoding of the same file  ( mplayer.log &
mencoder.log )

4. The faulty file
 I've uploaded it on the ftp. All is
    246tNt-data.mpg  -> The first 4 mb of the faulty file
    246tNt-desc.txt    -> A copy of this email
    246tNt-attch.tgz  -> The attachment of this mail in the standard
tar.gz format

( Note that these file are going to be uploaded and are maybe not
finished yet ...  i only have 8 ko/s in upload ... )

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 246tNt-attch.tgz
Type: application/octet-stream
Size: 13852 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/mplayer-users/attachments/20020104/b60e54b8/attachment.obj>

More information about the MPlayer-users mailing list