[Mplayer-users] Re:Signal 11 in init_video_codec

Ethan at stinkfoot.org Ethan at stinkfoot.org
Tue Oct 2 10:30:12 CEST 2001

Yes, both of these options (lfs, and dvd support) were disabled.  What 
bothers me is that this exact issue occurs on a Slackware version 8 
machine I compiled the software on as well.  
And although it's somewhat off-topic, I found that a very similar error 
occurs with recent versions of the 'avifile' code.
  The signal 11 is somewhere in the win32 loader code..I'm certain of it
  pe_image.c  ..specifically.  Perhaps this is being miscompiled?

Felix Buenemann wrote:

>On Tuesday, 2. October 2001 00:30, Ethan at stinkfoot.org wrote:
>>This worked with some files that hadn't previously, although .asf's
>>produce the same crash.
>>What's the story?
>if --disable-sse helps it's likely that simd code alignment probs cause the 
>If -vc odivx or -vc ffdivx helps it could be prob inside win32 codecs.
>Btw. have you already tried compiling without dvd and largefile support? It 
>seems to be the prob for S. Sommer.
>>Felix Buenemann wrote:
>>>On Sunday, 30. September 2001 22:26, Ethan at stinkfoot.org wrote:
>>>>Full bug report and gdb output...
>>>>1. System is a "linux from scratch", no distro.
>>>>2. Kernel is 2.4.10 final
>>>>3. Glibc is 2.2.4
>>>>4. X is 4.1.0 with Nvidia's binary driver
>>>>5. gcc is 2.95.3 with weak symbol and atexit() patch applied. ld is
>>>>2.11.2, as is 2.11.2 as well...
>>>>6. cpuinfo:
>>>>processor       : 0
>>>>vendor_id       : GenuineIntel
>>>>cpu family      : 6
>>>>model           : 8
>>>>model name      : Pentium III (Coppermine)
>>>please try ./configure --disable-sse and check if it still crashes (and
>>>try alternate divx codecs like .vc odivx or -vc ffdivx, needs
>>>divx4linux/ffmpegs libavcodec) and also try with -nosound.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mplayerhq.hu/pipermail/mplayer-users/attachments/20011002/a82e04e5/attachment.htm>

More information about the MPlayer-users mailing list