[Mplayer-users] SDL

Felix Buenemann atmosfear at users.sourceforge.net
Tue May 29 16:24:23 CEST 2001

On Monday, 28. May 2001 21:50, you wrote:
> I got very strange results when using SDL lately.
> Some time ago I've managed to run mplayer with aalib through SDL. It
> worked fine. Later I've upgraded to RedHat 7.1 and after some time I
> tried to run it again and it didn't work anymore. I'm using the same
> versions as before (SDL 1.2.0 with --enable-video-aalib and aalib
> 1.4.0). I'm thinking if it is mplayer's or SDL's (incompatibility with
> RedHat 7.1 libs) fault. Propably the second.
> I got segfault always when using SDL other than XV (-noxv, -sdl aalib,
> -sdl svga).
> mplayer -vo sdl -noxv:
> VO: [sdl] 352x240 => 352x240  YV12
> Fatal signal: Segmentation Fault (SDL Parachute Deployed)
> mplayer -vo sdl -sdl aalib:
> VO: [sdl] 352x240 => 352x240  YV12
> Using AAlib driver: Linux pc console driver 1.0 (linux)
> AAlib: signal 11 received
> Segmentation fault (core dumped)
> How to analyze CORE file to see what's wrong?
> Aalib itself (BB) works ok, SDL (when using XV) also works.
please try with mplayer -vo sdl -sdl aalib -zoom and report if it works.
> --
> Regards
> Havner
> alien at boss.staszic.waw.pl
> havner at wp.pl

Content-Type: text/html; charset="us-ascii"; name="Anhang: 1"
Content-Transfer-Encoding: 7bit

Best Regards,

Mplayer-users mailing list
Mplayer-users at lists.sourceforge.net

More information about the MPlayer-users mailing list