[Mplayer-users] SDL

havner alien at staszic.waw.pl
Mon May 28 21:50:34 CEST 2001

I got very strange results when using SDL lately.
Some time ago I've managed to run mplayer with aalib through SDL. It
worked fine. Later I've upgraded to RedHat 7.1 and after some time I
tried to run it again and it didn't work anymore. I'm using the same
versions as before (SDL 1.2.0 with --enable-video-aalib and aalib
1.4.0). I'm thinking if it is mplayer's or SDL's (incompatibility with
RedHat 7.1 libs) fault. Propably the second.
I got segfault always when using SDL other than XV (-noxv, -sdl aalib,
-sdl svga).

mplayer -vo sdl -noxv:
VO: [sdl] 352x240 => 352x240  YV12
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

mplayer -vo sdl -sdl aalib:
VO: [sdl] 352x240 => 352x240  YV12
Using AAlib driver: Linux pc console driver 1.0 (linux)
AAlib: signal 11 received
Segmentation fault (core dumped)

How to analyze CORE file to see what's wrong?
Aalib itself (BB) works ok, SDL (when using XV) also works.

Second strange thing is using esddsp. I can't get it working.
when I use
esddsp mplayer:
mplayer: error while loading shared libraries: libesddsp.so: cannot open
object file: No such file or directory

I got libesddsp.so and it is in proper lib dir
locate libesd:

This is very strange. Mplayer shouldn't look for libesddsp. This lib is
not in `ldd mplayer`.

When I run as root I don't get this message, mplayer runs, but sound
doesn't go throuh ESD either. ESD deamon is not even started. When I
start it manually it doesn't go through it anyway. After didn't getting
previous message when running as root I added set user id to esddsp, but
it didn't helped for normal user and I still get that mplayer can't find

Please help.


alien at boss.staszic.waw.pl
havner at wp.pl

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mplayerhq.hu/pipermail/mplayer-users/attachments/20010528/c59eb0fc/attachment-0001.htm>

More information about the MPlayer-users mailing list