[mplayer] MPEG-2 sound problem

Paul Holcomb mplayer at blue.cpoint.net
Mon Feb 19 09:08:37 CET 2001

 I've been unsucessful in getting any MPEG-2 videos to play correctly
 with sound.  I've tried both mpeg's that I have created with an
 encoder board and those from DVD's.

 They start out with the video displayed, but stopped, and the sound
 playing and then the player errors out on a bad frame, and the video starts.

 If I play the mpg with the -nosound option, the video is perfect, but
 even if I use the null output option the sound is broken.

 I've tried using the -noalsa and -delay options, with no change in

 I'm using a 2.4.1 kernel on an Athlon box with a Fiji Multisound card
 and the included OSS driver from the kernel for sound, output is
 through the syncfb driver (WORKS GREAT!), if any of this helps.

 Also, xine plays at least the mpeg-2 files from the encoder board
 with no sound problems.

 Here is a sample of a command line:

# ./mplayer -afm 1 -vo syncfb /MPEG-2/test.mpg 

MPlayer 0.11pre23       (C) 2000-2001 Arpad Gereoffy
<arpi at esp-team.scene.hu>

Detected MPEG-PS file format!
shmem: 1048576 bytes allocated using mmap anon (4052A000)
mpeg2dec-0.1.8-cvs (C) 2000 Aaron Holtzman <aholtzma at ess.engr.uvic.ca>
libmpeg2 config flags = 0xC0000000
shmem: 308 bytes allocated using mmap anon (40018000)
Using MMX for IDCT transform
Using 3DNOW for motion compensation
VIDEO:  MPEG2  704x480  (aspect 2)  30.00 fps  2812.5 kbps (351.6
using palette yuv420p3
BES Sourcer size: 704 x 480
Framebuffer memory: 16777216 in 4 buffers
Requesting first buffer #0
Got first buffer #0
shmem: 507936 bytes allocated using mmap anon (4162A000)
shmem: 507936 bytes allocated using mmap anon (416A7000)
shmem: 507936 bytes allocated using mmap anon (41724000)
shmem: 507936 bytes allocated using mmap anon (417A1000)
starting video codec...
mp3lib: Processor ID: 642
mp3lib: i586 processor detected.
mp3lib: AMD 3dnow! extension detected.
Audio buffer size: 262144 bytes, delay: 1.486s
Audio: type: 1  samplerate: 44100  channels: 2  bps: 2
Start playing...

DEMUXER: Too many (2048 in 4010196 bytes) video packets in the buffer!
(maybe you play a non-interleaved stream/file or video codec failed)

Broken frame at 0x33C92                                                  

Video codec started... (pid 744)

Any ideas?

Paul Holcomb                               *pholcomb    \@      cpoint  net*
Sr. Network Engineer                       Counterpoint Networking, Inc.

More information about the MPlayer-users mailing list