[Mplayer-users] Can't Display DivX ;-) on X11

Chris Starling chris at starling.cx
Wed Apr 18 00:41:01 CEST 2001

MPlayer works like a dream, with this one exception:  I can't get it to
play a DivX ;-) encoded file to the x11 output driver.  When I try, it
pops open a new window, but then it closes quickly.  However, if I run
it with the dga or null driver, it works fine.  Here is what it says on the 
command line when I run it with x11:

MPlayer 0.11cvs-010416-23:45  (C) 2000-2001 Arpad Gereoffy
<arpi at thot.banki.hu>

Reading config file: /etc/mplayer.conf: No such file or directory
Reading config file: /home/starling/.mplayer/config
Reading /home/starling/.mplayer/codecs.conf: 15 audio & 26 video codecs
Font /home/starling/.mplayer/font/font.desc loaded successfully! (140
Detected AVI file format!
VIDEO:  [DIV3]  720x480  24bpp  29.97 fps  1606.8 kbps (196.1 kbyte/s)
[V] filefmt:3  fourcc:0x33564944  size:720x480  fps:29.97
Found audio codec: [pcm] drv:2 (Uncompressed PCM)
AUDIO: samplerate=44100  channels=2  bps=2
Found video codec: [divxds] drv:4 (DivX ;-) (MS MPEG-4 v3))
X11 running at 1600x1200 depth: 32
Loading DLL: /usr/lib/win32/divx_c32.ax  OK
DivX setting result = 0
VO: [x11] 720x480 => 720x480  BGR32
Sharing memory.
X11 color mask:  R:FF0000  G:FF00  B:FF
Audio buffer size: 65536 bytes, delay: 0.372s
Start playing...

MPlayer interrupted by signal 4 in module: draw_frame 
vo: uninit!

I'm running:
Kernel 2.2.15
BlackBox 0.61.1

Is there something I've neglected to set properly?

Mplayer-users mailing list
Mplayer-users at lists.sourceforge.net

More information about the MPlayer-users mailing list