[MPlayer-DOCS] FAQ about compiling 32 bit mplayer on y86_64 is wrong

Wolfgang Knauf his-metality at freenet.de
Wed Oct 1 22:43:01 CEST 2008

Hi everybody,

the FAQ, section 5.2, "How can I build a 32 bit MPlayer on a 64 bit
Athlon?" seems to be wrong.

Following the instructions, it tried to build with this commandline:
./configure --target=athlon_xp --cc="gcc -m32" --as="as --32"
--enable-gui --with-extralibdir=/usr/lib

Compilation aborted while building "libdvdcss" with the error message
"DVD ioctls are unavailable on this system".

The reason seems to be that "configure" checks the "--target" parameter
and expects it to end with an OS name, e.g. "linux" or "freebsd". But 
for "athlon_xp", this resulted in an unknow OS "xp", so libdvdcss (and 
e.g. real media support) would not compile or not be activated.

It worked with:
./configure --target=i386-linux --cc="gcc -m32" --as="as --32"
--enable-gui --with-extralibdir=/usr/lib


Wolfgang Knauf

PS: I posted this on mplayer-users some days ago and later noticed that 
I was on the wrong mailing list. Sorry!

More information about the MPlayer-DOCS mailing list