[MPlayer-DOCS] CVS: main/help help_mp-en.h,1.243,1.244

The Wanderer inverseparadox at comcast.net
Mon Apr 24 21:28:06 CEST 2006

Sebastian Krämer wrote:

> Reynaldo H. Verdejo CVS wrote:

>> +#define MSGTR_LIBVO_SDL_BlitFailed "[VO_SDL] Blit failed: %s.\n"
> What is "blit"? I can't come up with a translation for it..

 From the Jargon File:

To copy a large array of bits from one part of a computer's memory to
another part, particularly when the memory is being used to determine
what is shown on a display screen. "The storage allocator picks through
the table and copies the good parts up into high memory, and then blits
it all back down again." See {bitblt}, {BLT}, {dd}, {cat}, {blast},
{snarf}. More generally, to perform some operation (such as toggling) on
a large array of bits while moving them.

Since the term is explicitly techie jargon, it may not actually need to
be translated.

>> +#define MSGTR_LIBVO_TDFXVID_GetImageTodo "Get image todo.\n"
> Does "todo" mean an item in a todo list?

I would expect so; it might be enlightening to look at the code from
which this is called.

>> +#define MSGTR_LIBVO_VESA_YourHaveTooSmallSizeOfVideoMemory "[VO_VESA] 
>> Your have too small size of video memory for this mode:\n[VO_VESA] 
>> Requires: %08lX exists: %08lX.\n"
> Typo/grammar: "Your have.."

And poor phrasing of the rest of it, as well. Something like
"Insufficient video memory for desired mode\nRequired:%08lX
Available:%08lX\n" might be better. (Actually I'd prefer to swap the
order of "available" and "required" as well, but that would need actual
code modification which doesn't seem justified offhand.)

>> +#define MSGTR_LIBVO_VESA_UsingBankSwitchingMode "[VO_VESA] Using bank 
>> switching mode (physical resources: %08lXh, %08lXh).\n"
> Can anybody elaborate what this "bank" is, please?

In older computer systems (the examples I'm most familiar with being
video game consoles, such as the NES and SNES), the computer could not
necessarily address all of its available physical memory at the same
time. The memory was therefore divided into distinct blocks of a
specific size (the SNES used 64K), small enough to all be available
simultaneously, and a method was provided to switch among these blocks
as necessary. These blocks were referred to as "banks".

As Guillaume did, I'll note that I'm not 100% certain that all of that
is accurate in the full technical sense, but I do know that it is
consistent with the way I have seen the word used in my own experience.

       The Wanderer

Warning: Simply because I argue an issue does not mean I agree with any
side of it.

Secrecy is the beginning of tyranny.

More information about the MPlayer-DOCS mailing list