[MPlayer-dev-eng] [PATCH 1/2] libmpdemux/mf: Replace sprintf by mp_asprintf
eclipse7 at gmx.net
Wed May 12 22:42:10 EEST 2021
On 2021-04-29 18:43 +0200, Alexander Strasser wrote:
> On 2021-04-28 21:09 +0200, Reimar Döffinger wrote:
> > A new variable local to this block would make it much easier to argue memory correctness.
> > This probably also applies to the other usages of this “fname” variable,
> > but that’s a somewhat separate issue.
> If you want to review it, I could try to refactor the
> individual ways to gather the file lists into individual
> functions. Localizing variables to those functions as
> much as possible.
Patch attached. Only lightly tested. First wanted to know
if you like it.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 4881 bytes
Desc: not available
More information about the MPlayer-dev-eng