[MPlayer-dev-eng] VAAPI/X11 video output driver

Andy Furniss adf.lists at gmail.com
Sat Nov 28 22:31:24 CET 2015

Mark Thompson wrote:
> On 28/11/15 18:57, Andy Furniss wrote:
>> Andy Furniss wrote:
>>> There is also an issue when full screen with anamorphic. It fills the
>>> screen OK, but while the overlay is displayed there is a chance of
>>> some corruption  over the picture and depending on size of vid tested
>>> the overlay its self may be chopped off.
>> In fact saying anamorphic above is wrong, anything fullscreen that gets
>> scaled will do. The corruption seems to be random/old gpu mem contents
>> and it usualy varies with each overlay draw - eg repeatedly pressing /
>> or * to adjust volume will get different corruption each press.
>> On my 1920x1080 monitor content the same res does not have the issue.
>> When lower res content is displayed in initial window there is no
>> corruption.
>> I just tried making bigger the initial window and using overlay and got -
>> MPlayer interrupted by signal 11 in module: flip_page
> This is all totally fine for me (upscale, downscale, fullscreen with
> upscale, fullscreen with downscale, OSD on top of all of those things).
> Can you describe precisely how you got that crash, and ideally a
> backtrace to go with it?

To get this I started playing in a window then stretched the window to 
make it bigger then made OSD appear.

It is possible to do this without crashing - corruption is seen instead.

Looks like it's a gallium thing - I run git mesa and there have been a 
few changes around va/vaapi recently.

Program received signal SIGSEGV, Segmentation fault.
__memcpy_sse2 () at ../sysdeps/x86_64/multiarch/../memcpy.S:273
273     ../sysdeps/x86_64/multiarch/../memcpy.S: No such file or directory.
(gdb) bt
#0  __memcpy_sse2 () at ../sysdeps/x86_64/multiarch/../memcpy.S:273
#1  0x00007fffea5a599c in util_copy_rect (dst=<optimized out>, 
format=<optimized out>, dst_stride=<optimized out>, dst_x=0, 
dst_y=<optimized out>, width=2880, height=576,
     src=0x555557797060 <error: Cannot access memory at address 
0x555557797060>, src_stride=3528, src_x=0, src_y=<optimized out>) at 
#2  0x00007fffea54630f in upload_sampler (src_x=<optimized out>, 
src_y=<optimized out>, dst=<optimized out>, src_stride=<optimized out>, 
src=<optimized out>, dst_box=<optimized out>, pipe=<optimized out>) at 
#3  vlVaPutSubpictures (surf=<optimized out>, surf=<optimized out>, 
dst_rect=<optimized out>, src_rect=<optimized out>, 
dirty_area=<optimized out>, surf_draw=<optimized out>, drv=<optimized 
out>) at surface.c:209
#4  vlVaPutSurface (ctx=0x7fffe6fc4780, surface_id=1467576416, 
draw=0x7fffffffd1a0, srcx=360, srcy=1, srcw=720, srch=576, destx=0, 
desty=104, destw=881, desth=496, cliprects=0x0, number_cliprects=0, 
flags=18) at surface.c:277
#5  0x00005555556f952d in put_surface_x11 (surface=<optimized out>) at 
#6  put_surface (surface=0x7fffe6fc4780) at libvo/vo_vaapi.c:2250
#7  0x00005555556f9ad9 in flip_page () at libvo/vo_vaapi.c:2401
#8  0x00005555556c078d in main (argc=4, argv=0x7fffffffe458) at 

> I also tried anamorphic video.  There is something a bit strange going
> on because I got the behaviour you described with extra black bars when
> playing in a window, but it did the right thing once it went fullscreen.
>   Maybe it's just that the window is made initially with the wrong
> aspect ratio?

Yes, I tried with a different 16/9 sample 544x576 and that is the size 
of the initial window.

More information about the MPlayer-dev-eng mailing list