[MPlayer-dev-eng] error: unknown option `ff-only' while configuring mplayer

Srilatha Addanki srilatha.addanki at vayavyalabs.com
Fri Sep 30 09:11:55 CEST 2011

Hi all,

I got mplayer source code from svn using *svn checkout svn://
svn.mplayerhq.hu/mplayer/trunk mplayer *and i am trying to build mplayer for
arm board so trying to configure.

Tried with just ./configure and also with few options relevant to arm target
board, in both ways of configuring i am getting the  unknown option
`ff-only' error and the total error message is:

*error: unknown option `ff-only'*
*usage: git fetch [options] [<repository> <refspec>...]*
*    -v, --verbose         be more verbose*
*    -q, --quiet           be more quiet*
*    -a, --append          append to .git/FETCH_HEAD instead of overwriting*
*    --upload-pack <PATH>  path to upload pack on remote end*
*    -f, --force           force overwrite of local branch*
*    -t, --tags            fetch all tags and associated objects*
*    -n                    do not fetch all tags (--no-tags)*
*    -k, --keep            keep downloaded pack*
*    -u, --update-head-ok  allow updating of HEAD ref*
*    --depth <DEPTH>       deepen history of shallow clone*
*git pull failed, (re)move ffmpeg/mp_auto_pull to disable pulling*

I tried to google and find out solution if any, but did not find any
solution. If any one knows why i am getting this error and what needs to be
done to come out of this error, Please suggest me.


More information about the MPlayer-dev-eng mailing list