[MPlayer-dev-eng] [MPlayer-cvslog] r34099 - in trunk/libass: ass.c ass.h ass_bitmap.c ass_bitmap.h ass_cache.c ass_cache.h ass_drawing.c ass_font.c ass_font.h ass_fontconfig.c ass_fontconfig.h ass_library.c ass_library.h ass_parse.c...

Erik Auerswald auerswal at unix-ag.uni-kl.de
Sun Sep 18 14:41:00 CEST 2011


On 09/17/2011 04:25 PM, Reimar Döffinger wrote:
> On Tue, Sep 13, 2011 at 04:31:27PM +0200, Erik Auerswald wrote:
>> On Tue, Sep 13, 2011 at 03:58:56PM +0200, Diego Biurrun wrote:
>>> On Tue, Sep 13, 2011 at 02:39:19PM +0200, Erik Auerswald wrote:
>>>> On Tue, Sep 13, 2011 at 01:51:45PM +0200, Diego Biurrun wrote:
>>>>> On Tue, Sep 13, 2011 at 09:09:49AM +0200, Erik Auerswald wrote:
>>>>>> On Mon, Sep 12, 2011 at 06:12:41PM +0200, Reimar Döffinger wrote:
>>>>>>> [...]
>>>>>>> If we want to remove things: Does anyone remember a reason to keep
>>>>>>> mp3lib? Because that one is high-cost in comparison.
>>>>>> I currently need mp3lib because the default mpg123 crashes on every mp3
>>>>>> file I have.
>>>>> What do you mean by "default mpg123"?
>>>> That MPlayer decides to use the mpg123 (based?) code by default.
>>> I'm still not following.  Is "default mpg123"
>>> a) what MPlayer carries along in the mp3lib/ directory or
>>> b) the upstream libmpg123 from mpg123.de (which version)?
>> I'll check when I'm back at my home system (not before Friday). I suppose
>> configure output and existing system librarys should be enough to decide
>> this. If system libs are used, they are from Debian/Sid, last updated
>> Sunday.
>> Anyway, If I specify "-afm mp3lib" I can play mp3 files and videos with
>> included mp3 audio. If I don't specify -afm ..., mplayer crashes when
>> trying to play an mp3.
>> What I am trying to say is that I need mp3lib support. I don't currently
>> know if the version included in mplayer is used or some system lib. I
>> assumed that the included code is used without even checking for a system
>> wide replacement; I don't specify anything mp3 related when calling
>> configure. But I don't know for sure and cannot check at the moment.
> You are aware of ffmp3?
> mp3lib is marked as broken in codecs.conf, so nobody is using that
> nowadays unless they compiled FFmpeg without mp3 support.

I am now... didn't really care as long as everything worked. When the 
problems with mp3 files started, I discovered mp3lib first and stopped 

After compiling without libmpg123 support, -afm ffmpeg was used, which 
works as well.

> Which also means that compiling without mpg123 support would
> "fix" your issue.

There are several ways to "fix" (i.e. work around) my issue:

1) using -afm ffmpeg or -afm mp3lib for files with mp3 audio
2) configuring with --disable-mp3lib
3) configuring with --disable-mpg123
4) removing the libmpg123 development headers from the system

I went with 4) since I had them installed for MPlayer only and libmpg123 
is supposedly broken on Debian/Sid currently.

> My concern now is mostly about making sure that no significant
> optimizations are lost when removing our heavily modified mp3lib.

ffmp3float seems to be faster on my system:

Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, floatle, 192.0 kbit/6.80% (ratio: 24000->352800)
Selected audio codec: [ffmp3float] afm: ffmpeg (FFmpeg MPEG layer-3 audio)
AO: [null] 44100Hz 2ch floatle (4 bytes per sample)
Video: no video
Starting playback...
A: 271.7 (04:31.6) of 358.0 (05:58.0)  0.9% 0%
Audio output truncated at end.
A: 271.7 (04:31.6) of 358.0 (05:58.0)  0.9% 0%

BENCHMARKs: VC:   0.000s VO:   0.000s A:   2.433s Sys: 276.795s =  279.228s
BENCHMARK%: VC:  0.0000% VO:  0.0000% A:  0.8712% Sys: 99.1288% = 100.0000%

Trying to force audio codec driver family mp3lib...
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
AO: [null] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 271.6 (04:31.6) of 538.0 (08:58.0)  1.1% 0%
Audio output truncated at end.
A: 271.6 (04:31.6) of 538.0 (08:58.0)  1.1% 0%

BENCHMARKs: VC:   0.000s VO:   0.000s A:   2.998s Sys: 276.480s =  279.478s
BENCHMARK%: VC:  0.0000% VO:  0.0000% A:  1.0728% Sys: 98.9272% = 100.0000%

$ cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 28
model name      : AMD Sempron(tm) Processor 3000+
stepping        : 0
cpu MHz         : 1000.000
cache size      : 128 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge 
mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt 
3dnowext 3dnow up lahf_lm
bogomips        : 2009.83
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 32 bits virtual
power management: ts fid vid ttp

[CPU clock stays at 1GHz while playing mp3, will go to 1.8GHz if needed. 

Hm, just noticed the different reported bitrates (192kbps for ffmpeg, 
128kbps for mp3lib). mpg123 (the standalone player) reports "MPEG 1.0 
layer III, VBR, 44100 Hz stereo" for the used file.

Anyway, I don't need mp3lib any more, feel free to remove it. Or perhaps 
just disable it in configure by default.


More information about the MPlayer-dev-eng mailing list