[MPlayer-dev-eng] [PATCH]Add vo vdpau
Reimar.Doeffinger at stud.uni-karlsruhe.de
Mon Jan 5 11:00:36 CET 2009
On Mon, Jan 05, 2009 at 09:09:55AM +0000, Carl Eugen Hoyos wrote:
> > is copied from an older version of vo_xv.c from before Reimar changed
> > it.
> I was hoping he (or somebody else) who has more insight than myself could
> quickly point me to these issues.
At least the changes from the following SVN revisions probably need to be applied to it:
r27924, r27926, r27937, r27942, r27946, r27961, r27978, r27980, r27986
Though I did not check if all of them apply to it.
About CHECK_ST: it should not be needed. The checks should be explicitly
in the code and not obfuscated by a macro.
To help this you should get rid of the insane code duplication due to
In gl_common.c the extfuncs array and the getFunctions function would be
one example of how to do it, though it seems to me that it should be
quite a bit simpler for VDPAU since you do not have to deal with things
like extension strings and the same function having different names.
More information about the MPlayer-dev-eng