[MPlayer-dev-eng] [bikeshed] Coding style
Luca Barbato
lu_zero at gentoo.org
Mon Jun 16 14:29:13 CEST 2008
Michael Niedermayer wrote:
> I do not like spaces, i like ommiting {} if and only if it does
> cost a extra line. 4 space indention, no tabs (or only tabs),
> switch&case on the same indention level, ...
>
> if(){
> X;
> }else if(){
> Y;
> }else
> Z;
I find this harder to read for the {} but I'm fine with sparing lines.
> type var= value;
>
> type *var= value;
I guess that's a good compromise between
type *var=value;
and
type *var = value;
> switch(){
> case a:
> aaa
> break;
> case b:
> bbb
> break;
> }
I'm fine with it beside brackets.
> PS: and of course stuff vertically aligned where it helps readability. That
> is
Agreed.
if we get a 1/2 split on the bracket+spaces I'd go having just that
relaxed per file, the readability difference is negligible.
lu
--
Luca Barbato
Gentoo Council Member
Gentoo/linux Gentoo/PPC
http://dev.gentoo.org/~lu_zero
More information about the MPlayer-dev-eng
mailing list