[MPlayer-dev-eng] [PATCH] get rid of my_memcpy_pic code duplication
michaelni at gmx.at
Mon Jun 25 21:27:16 CEST 2007
On Mon, Jun 25, 2007 at 10:05:23AM +0200, Reimar Doeffinger wrote:
> On Sun, Jun 24, 2007 at 09:33:01PM +0200, Michael Niedermayer wrote:
> > On Sun, Jun 24, 2007 at 02:58:09PM +0200, Reimar Döffinger wrote:
> > > Seems rather stupid that each filter has this filter copy-and-pasted
> > > (esp. since they also do void * arithmetic).
> > > I have not properly benchmarked it, but I don't think there is even a
> > > real need for those functions to be static inline at all.
> > > Ok to apply?
> > IMHO yes but i think my_memcpy_pic() should be renamed after that, its name is
> > not really related to the difference to memcpy_pic()
> Sure, I was just lazy to do all the changing right now.
> Have a good suggestion for a name?
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
Many that live deserve death. And some that die deserve life. Can you give
it to them? Then do not be too eager to deal out death in judgement. For
even the very wise cannot see all ends. -- Gandalf
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
More information about the MPlayer-dev-eng