[MPlayer-dev-eng] [PATCH] new pvr demuxer support
ben at geexbox.org
Sat Jul 8 18:51:51 CEST 2006
On Sat, 8 Jul 2006 17:10:11 +0200
Reimar Döffinger <Reimar.Doeffinger at stud.uni-karlsruhe.de> wrote:
> On Sat, Jul 08, 2006 at 04:53:02PM +0200, Benjamin Zores wrote:
> > btw, out of curiosity, why do we have dvbin.c and not stream_dvb.c then ?
> Because IIRC it is old code before a "proper" stream layer and the
> naming scheme existed.
> I think renaming those after the switch to SVN was actually discussed at
> some point, probably it was simply forgotten after all that time that
> passed since.
Well it can be fine to proceed to some reordering of libmpdemux which contains a lot of files.
Some are muxers, some are demuxers, others are input.
It may be good to make some subdirs for each kind of file and to have all of them well named.
I agree it was doable with cvs but if we'd switched to svn, let's use its potential.
Going further, all stream_* files should belong to something else than libmpdemux.
As you've said with my "demuxer" (which is an input layer only), these files do not mux or
demux anything, it's only transport.
Just my .02$
"My life, and by extension everyone else's is meaningless."
More information about the MPlayer-dev-eng