[MPlayer-dev-eng] XviD 1.1.x support
Reimar.Doeffinger at stud.uni-karlsruhe.de
Thu Sep 30 23:29:04 CEST 2004
>>It seems to me that you mostly renamed xvid_ini to xvid_gbl_init and
>>dec_p to xvid_dec_create. This makes it more difficult to both
>>understand the patch and track possible bugs introduced by it. If you
>>really want it for readability reasons, I'd say put it in a separate patch.
> Ok, I'm gonna first commit a patch that features that cosmetics that, I
> agree, don't change anything besides readability, but have to be done in
> order to have this front-end in sync with Edouard's.
Is there a chance of him getting his frontend a bit more in sync with
And an extra patch with cosmetics to be applied _afterwards_ would
probably be more acceptable for most.
>>Doxygen style comments are required now, see
> Hum... Given that it's not my code, I wonder if it would be a good idea
> for me to write " maybe wrong" comments.
> Heck, if it's required, I'll do it, just be warned!
I guess even those maybe-wrong comments are better than none. If they're
wrong they will be corrected somewhen, if there are none that will
probably stay like that.
> The attached patch feature the name change that'll make the move to
> 1.1.x smoother.
> I no one complains, I'll commit that in 3 day...
I don't like it, but if you want do it. Although I thought about that
renaming and I am not sure that it really improves readability.
It changes the variable names to be the same as the type names, which
doesn't fit the criteria that variable names should describe what they
do / what they are used for. Not that the old names seem to be better...
More information about the MPlayer-dev-eng