[MPlayer-dev-eng] [BUG] DVB input/MPEG-TS not working correctly

Nico nsabbi at libero.it
Fri Aug 22 22:39:07 CEST 2003


>It does not seem to be that trivial.  I increased MAX_PACKS as you told
>me, MAX_PACKS_BYTES was already set to 0x800000.  This just delays the
>error, and I can better watch it happen: Video doesn't play fast enough,
>although audio is already ahead of video!  The delay gets greater and
>greater, and after about 10 seconds, I again see "Too many video packets
>in the buffer: (32768 in 5996283 bytes)".  Haven't tried your patch yet,
>here's one of the status lines while that effect is happening:
>A:78581.4 V:78574.7 A-V:  6.662 ct:  0.088   25/ 25  30% 34% 808.9% 24 0 0%

I tried to play that file, and it plays perfectly for me, both with the old
and the new demuxer and both vith -vo xv and -vo x11.
It's impossible to tell if its audio in sync, as the audio stream isn't spoken by the 
man in the foreground, but I didn't have any 'too many video packets ...' message.
It's too small to verify your problem.

>And I noticed yet another bug: 
>tzap -r "ZDF" & sleep 1; mplayer dvb://ZDF
>MPlayer interrupted by signal 11 in module: open_stream
>Of course the command makes no sense, but that's no reason to just
>segfault.  I currently have no debug version of mplayer around, so no
>backtrace this time.  I'll send one if you cannot reproduce that bug.
>Watching TV without zapping is just no fun.  Hope those problems can be
>fixed.  If you need more info, just ask.

In this case you are trying to have the tuner open both by tzap and 
mplayer at the same time.
This can't be done, but obviously  there's a bug in my code that doesn't 
check the failure of open();
I'll fix it, thanks for reporting.

The right command is

tzap -r "ZDF" & sleep 1; mplayer < /dev/dvb/adapter0/dvr0

BTW, Can you post your channels.conf file, please?


More information about the MPlayer-dev-eng mailing list 

More information about the MPlayer-dev-eng mailing list