[MPlayer-cvslog] r35884 - trunk/gui/interface.c

Alexander Strasser eclipse7 at gmx.net
Fri Jan 25 20:45:30 CET 2013


Hi Ingo,

ib wrote:
> Author: ib
> Date: Fri Jan 25 16:42:36 2013
> New Revision: 35884
> 
> Log:
> Cosmetic: Rename variable.
> 
> Modified:
>    trunk/gui/interface.c
> 
> Modified: trunk/gui/interface.c
> ==============================================================================
> --- trunk/gui/interface.c	Fri Jan 25 16:39:18 2013	(r35883)
> +++ trunk/gui/interface.c	Fri Jan 25 16:42:36 2013	(r35884)
> @@ -77,7 +77,7 @@ static int initialized;
>   */
>  void guiInit(void)
>  {
> -    int i;
> +    int r;
>      plItem *playlist;

  Wouldn't "ret" have been a better name for this variable?

  I mean "i" is well known variable name and IMHO not appropriate here. But "r"
is quite untypical to my knowledge, whereas "ret" is probably widely understood
for variables holding return codes either returned from a function called or for
the function itself or both.

  Of course you are free to name it as you prefer in the GUI code!


  Alexander

>      mp_msg(MSGT_GPLAYER, MSGL_V, "GUI init.\n");
> @@ -125,16 +125,16 @@ void guiInit(void)
>      if (!skinName)
>          skinName = strdup("default");
>  
> -    i = skinRead(skinName);
> +    r = skinRead(skinName);
>  
> -    if (i == -1 && strcmp(skinName, "default") != 0) {
> +    if (r == -1 && strcmp(skinName, "default") != 0) {
>          mp_msg(MSGT_GPLAYER, MSGL_WARN, MSGTR_SKIN_SKINCFG_SelectedSkinNotFound, skinName);
>  
>          skinName = strdup("default");
> -        i = skinRead(skinName);
> +        r = skinRead(skinName);
>      }
>  
> -    switch (i) {
> +    switch (r) {
>      case -1:
>          gmp_msg(MSGT_GPLAYER, MSGL_FATAL, MSGTR_SKIN_SKINCFG_SkinNotFound, skinName);
>          mplayer(MPLAYER_EXIT_GUI, EXIT_ERROR, 0);


More information about the MPlayer-cvslog mailing list