[MPlayer-cvslog] r33121 - trunk/stream/stream_dvdnav.c
reimar
subversion at mplayerhq.hu
Sat Mar 26 21:22:43 CET 2011
Author: reimar
Date: Sat Mar 26 21:22:43 2011
New Revision: 33121
Log:
Use fewer () to make code more readable.
Modified:
trunk/stream/stream_dvdnav.c
Modified: trunk/stream/stream_dvdnav.c
==============================================================================
--- trunk/stream/stream_dvdnav.c Sat Mar 26 21:04:47 2011 (r33120)
+++ trunk/stream/stream_dvdnav.c Sat Mar 26 21:22:43 2011 (r33121)
@@ -464,7 +464,7 @@ static int control(stream_t *stream, int
}
case STREAM_CTRL_SEEK_TO_TIME:
{
- uint64_t tm = (uint64_t) (*((double*)arg) * 90000);
+ uint64_t tm = *(double *)arg * 90000;
if(dvdnav_time_search(priv->dvdnav, tm) == DVDNAV_STATUS_OK)
return 1;
break;
More information about the MPlayer-cvslog
mailing list