[MPlayer-cvslog] r25897 - in trunk: libass/mputils.h libmpcodecs/ae.h libmpcodecs/ae_faac.h libmpcodecs/ae_toolame.h libmpcodecs/ae_twolame.h libmpcodecs/mpc_info.h libmpcodecs/native/mmx.h libmpcodecs/vqf.h libmpdemux/demux_xmms_plugin.h libvo/f
Reimar.Doeffinger at stud.uni-karlsruhe.de
Mon Jan 28 16:37:39 CET 2008
On Mon, Jan 28, 2008 at 04:43:28PM +0200, Ivan Kalvachev wrote:
> On Jan 28, 2008 3:55 AM, Ivan Kalvachev <ikalvachev at gmail.com> wrote:
> > On Jan 28, 2008 3:32 AM, diego <subversion at mplayerhq.hu> wrote:
> > > Author: diego
> > > Date: Mon Jan 28 02:32:52 2008
> > > New Revision: 25897
> > >
> > > Log:
> > > Consistently use uppercase filename as multiple inclusion guard.
> Ok, it seems that I need to clarify what the problem is.
> Diego where have you read that the definition used in multiple
> inclusion guard must follow the filename excactly? Is that rule you
> made up by yourself using common sense or you read it somewhere? Have
> you asked some skilled developer about this change or you just went
> away and did what you wanted?
Well, most files already did that just that they
appended/prepended/whatever randomly _ or similar things, that help
little to avoid collisions.
Which is why the whole big load of similar changes so far were ok, they
made things consistent while not making anything worse.
Nevertheless I agree that removing that ASS_ was a bad idea (though IMO
having LIBASS_ as prefix would have made more sense), even more so since
libass is also a standalone library, not only used in MPlayer.
Diego, have you time to change/revert that part before the flamefest
risks to break loose, or should I do it?
And is anyone (particularly the maintainer) against using LIBASS_
instead of ASS_, and consistently use LIBASS_FILENAME as name (if that
is not already the case)?
More information about the MPlayer-cvslog