[MEncoder-users] real time output to rtmp

Claudiu Rad-Lohanel jazzman at misalpina.net
Mon Jun 17 17:29:54 CEST 2013

hello everybody,

i am trying to output a local video to a rtmp server and of course i 
need to do it in realtime. i've tried set -ofps option to 25 (same as 
source) but it doesn't work.
this is what i'm currently running:

mencoder.exe c:\temp\vc1\mms.wmv -vf harddup -ovc x264 -x264encopts 
pass=1:turbo:bitrate=600:bframes=1 -oac mp3lame -lameopts cbr:br=96 
-srate 44100 -ofps 25 -of lavf -lavfopts format=flv -o 

unfortunately the file is encoded and streamed to the server @ ~90fps

i have little experience with mencoder/mplayer so excuse me if i make 
some obvious mistakes.
i am using latest mencoder/ffmpeg builds.

if what i want to do is not possible, let me explain the background of 
what i'm doing, maybe you, experienced users have a different approach:
basically i want to restream an RTSP-MS (microsoft) stream to a regular 
rtmp server. unfortunately i can't change anything on the source side to 
make changes to codec/format/protocol so i am stuck with RTSP-MS which 
has some non-standard microsoft modifications as transport protocol 
combined with some VC1 advanced profile video codec which seems to be 
decoded only by using w32codecs.
the first step was to capture the rtsp stream properly which was very 
difficult because of microsoft modifications (no popular open-source 
tool like vlc/ffmpeg/etc could properly read the stream). i've managed 
to do that and created local wmv dumps to continue development.
due to the VC1 profile used, latest ffmpeg for example still fails to 
decode that complaining that "Progressive Segmented Frame mode: not 
supported (yet)" so that's how i've got in touch with mencoder which can 
use w32codecs and properly decode the dump.
the problem is that i'm fighting now to use somehow mencoder to reencode 
and stream to rtmp. i've tried chaining mencoder output with ffmpeg with 
rtmp output option but i am having problems chaining them together, 
almost nothing works: "pipe:: Invalid data found when processing input" 
and unfortunately can't find really good examples of piping mencoder 
output to ffmpeg for further processing for example.
of course, when piping i've used the -really-quiet mencoder option 
without success.

any ideas that can help achieving my task? it seems like i must put 
mencoder somehow into the equation for the wvc1dmod.dll decoder (ffmpeg 
doesn't want to use windows binary codecs by principle, but they fail to 
decode my stream 

also, as a side issue, does anybody know why i make tens of searches on 
google.com using 'mencoder' keyword and almost all results are ffmpeg 
related (ffmpeg highlighted)? it's like google translates my searches 
from "mencoder ..." to "ffmpeg ...", it's almost impossible to find 


-------------- next part --------------
A non-text attachment was scrubbed...
Name: jazzman.vcf
Type: text/x-vcard
Size: 263 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/mencoder-users/attachments/20130617/23fa4dfb/attachment.vcf>

More information about the MEncoder-users mailing list