[MEncoder-users] AC3 and Strange Video Playback

Nigel Arnold nkarnold at googlemail.com
Fri Dec 21 11:39:41 CET 2007

OK, I've Changed the command line to
mencoder dvd://1 -dvd-device R:\  -oac lavc  -ovc lavc -lavcopts 
vcodec=mpeg4:vbitrate=1024:acodec=ac3:abitrate=384 -channels 6 -af 
channels=6 -of lavf -lavfopts format=avi -aid 0x80  -ofps 
24000/1001 -Chapter 03-03  -o "AC3Test.avi"

Exactly same problem, i can see in the mencoder output, it is now using the 
lavf muxer, but the resulting file is the same in terms of playback issues.

"Giacomo Comes" <comes at naic.edu> wrote in message 
news:20071220142946.GA5504 at monopoli.naic.edu...
> On Thu, Dec 20, 2007 at 01:19:12PM -0000, Nigel Arnold wrote:
>> Hello
>> I'm getting a problem creating any MPEG4 AVI with any AC3 audio track.
>> I've tried RC2 and also a 25088 build as provided by Sherypa
>> I''ve stripped back to a very basic bare command line,
>> mencoder dvd://1 -dvd-device R:\  -oac lavc  -ovc lavc -lavcopts
>> vcodec=mpeg4:vbitrate=1024:acodec=ac3:abitrate=192  -ofps
>> 24000/1001 -Chapter 03-03  -o "AC3 Test.avi"
>> The resulting .avi file -
>> 1. The video plays about 2-3 times faster than speed than normal (like a
>> Fast forward) in VLC, and WMP
>> 2. The video is not seekable, as soon as I position in VLC, the video 
>> ends,
>> in WMP If i seek, the video stops, audio still plays and takes about 10
>> minutes for the video / audio to start playing again.
>> This appears to be only related to AC3, as if I choose libmp3lame or
>> libfaac, the video's are fine.
>> I've tried the above command with a much earlier build 21190 and it works
>> fine. the resulting video file plays fine in VLC, WMP and MPlayer
>> Any Ideas
>> Thx in advance
> It a old bug.
> See 
> http://lists.mplayerhq.hu/pipermail/mencoder-users/2007-December/007644.html
> Giacomo 

More information about the MEncoder-users mailing list