[MEncoder-users] x264 file playback is too slow!

Raphael mencoder at lesshaste.plus.com
Wed Mar 22 22:46:41 CET 2006

Corey Hickey wrote:
> Raphael wrote:
>> How do you get mencoder to output the audio in a format another audio
>> encoder can use?
>>  mencoder k3b_image.iso -oac pcm  -ovc frameno  -endpos 120 -o k3b.wav
>> is not usable by oggenc for example.
> That's because it's not really a wave file, even though you call it
> one. It's still an avi file.
> $ mplayer k3b_image.iso -ao pcm:file=k3b.wav \
>   -vc null -vo null -benchmark
> -Corey

Thanks. I tried that method first but it has two problems.

1) I don't see how to do the equivalent of -endpos 120


2) It runs very slowly and is generally rather odd. Here is the full
mplayer -v output attached. See how it complains that I don't have -vo
null etc. and then says my system is too slow to play the file!



MPlayer dev-CVS-060212-08:34-3.4.4 (C) 2000-2006 MPlayer Team
CPU: Advanced Micro Devices Athlon 64 Newcastle,Winchester,San Diego,Venice; Sempron Palermo 1790 MHz (Family: 15, Stepping: 0)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2

get_path('codecs.conf') -> '/home/raph/.mplayer/codecs.conf'
Reading /home/raph/.mplayer/codecs.conf: 91 audio & 205 video codecs
CommandLine: '-v' 'k3b_image.iso' '-ao' 'pcm:file=k3b.wav' '-vc' 'null' '-vo' 'null' '-benchmark'
get_path('font/font.desc') -> '/home/raph/.mplayer/font/font.desc'
Font /home/raph/.mplayer/font/font.desc loaded successfully! (206 chars)
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using nanosleep() timing
get_path('input.conf') -> '/home/raph/.mplayer/input.conf'
Can't open input config file /home/raph/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
get_path('k3b_image.iso.conf') -> '/home/raph/.mplayer/k3b_image.iso.conf'
Playing k3b_image.iso.
get_path('sub/') -> '/home/raph/.mplayer/sub/'
[file] File size is 4148838400 bytes
STREAM: [file] k3b_image.iso
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for NuppelVideo
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename k3b_image.iso ext: .iso
Checking for Nullsoft Streaming Video
Checking for MOV
Checking for VIVO
header block 1 size: 0
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 33216, FOUND 0, packet_size= 0, SEEMS A TS? 0
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=0 size=-8
LMLM4 Stream Format not found
system stream synced at 0x9200D (598029)!
==> Found video stream: 0
==> Found audio stream: 128
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)  
MPEG-PS file format detected.
Searching for sequence header... OK!
VIDEO:  MPEG2  720x576  (aspect 2)  25.000 fps  8800.0 kbps (1100.0 kbyte/s)
[V] filefmt:2  fourcc:0x10000002  size:720x576  fps:25.00  ftime:=0.0400
get_path('sub/') -> '/home/raph/.mplayer/sub/'
get_path('default.sub') -> '/home/raph/.mplayer/default.sub'
Opening audio decoder: [liba52] AC3 decoding with liba52
dec_audio: Allocating 3840 bytes for input buffer.
dec_audio: Allocating 6144 + 65536 = 71680 bytes for output buffer.
Using SSE optimized IMDCT transform
AC3: 2.0 (stereo)  48000 Hz  224.0 kbit/s
A52 flags before a52_frame: 0x2A
A52 flags after a52_frame: 0x2
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 224.0 kbit/14.58% (ratio: 28000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
Forced video codec: null
Opening video decoder: [null] Null video decoder
VDec: vo config request - 720 x 576 (preferred colorspace: BGR 24-bit)
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO Config (720x576->768x576,flags=0,'MPlayer',0x32315659)
VO: [null] 720x576 => 768x576 Planar YV12 
VO: Description: Null video output
VO: Author: Aaron Holtzman <aholtzma at ess.engr.uvic.ca>
Selected video codec: [null] vfm: null (NULL codec (no decoding!))
Building audio filter chain for 48000Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy 
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[AO PCM] File: k3b.wav (WAVE)
PCM: Samplerate: 48000Hz Channels: Stereo Format s16le
[AO PCM] Info: Faster dumping is achieved with -vc null -vo null
[AO PCM] Info: To write WAVE files use -ao pcm:waveheader (default).
AO: [pcm] 48000Hz 2ch s16le (2 bytes per sample)
AO: Description: RAW PCM/WAVE file writer audio output
AO: Author: Atmosfear
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
Starting playback...


           **** Your system is too SLOW to play this!  ****

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver
  - Try -ao sdl or use the OSS emulation of ALSA.
  - Experiment with different values for -autosync, 30 is a good start.
- Slow video output
  - Try a different -vo driver (-vo help for a list) or try -framedrop!
- Slow CPU
  - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
    e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
- Broken file
  - Try various combinations of -nobps -ni -forceidx -mc 0.
- Slow media (NFS/SMB mounts, DVD, VCD etc)
  - Try -cache 8192.
- Are you using -cache to play a non-interleaved AVI file?
  - Try -nocache.
Read DOCS/HTML/en/video.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.


More information about the MEncoder-users mailing list